Compose Extension: One command, displayed twice

%3CLINGO-SUB%20id%3D%22lingo-sub-1150497%22%20slang%3D%22en-US%22%3ECompose%20Extension%3A%20One%20command%2C%20displayed%20twice%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1150497%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3CBR%20%2F%3EI%20have%20a%20custom%20application%20in%20Teams%2C%20with%20a%20bot%20running.%20I%20use%20App%20Studio%20for%20the%20creation%20process.%3C%2FP%3E%3CP%3EI%20have%20added%20a%20Messaging%20extension%20with%201%20command%20and%201%20param%20(to%20test%20this%20functionality)%2C%20with%20'Compose%20Box'%20option%20selected.%3C%2FP%3E%3CP%3EMy%20problem%20is%20I%20see%20twice%20the%20command%20when%20I%20open%20'What%20can%20I%20do%3F'%20in%20Teams%20client.%3C%2FP%3E%3CP%3EIn%20the%20manifest%20there%20is%20only%20one%20command%20in%20the%20composeExtensions%20vector.%3C%2FP%3E%3CP%3EWhere%20can%20be%20the%20problem%3F%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EThanks%20in%20advance%2CDiego%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1150497%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1151748%22%20slang%3D%22en-US%22%3ERe%3A%20Compose%20Extension%3A%20One%20command%2C%20displayed%20twice%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1151748%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F402611%22%20target%3D%22_blank%22%3E%40diegoSpace%3C%2FA%3E%26nbsp%3BCould%20you%20please%20check%20if%20you%20have%20installed%20multiple%20instances%20of%20the%20app%20in%20other%20teams%2C%20delete%20them%20and%20have%20a%20single%20instance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1152799%22%20slang%3D%22en-US%22%3ERe%3A%20Compose%20Extension%3A%20One%20command%2C%20displayed%20twice%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1152799%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F359599%22%20target%3D%22_blank%22%3E%40Gousia_Begum%3C%2FA%3E%26nbsp%3BI%20have%20installed%20this%20app%20only%20in%20one%20team%2C%20but%20i%20do%20see%20the%20application%20twice%20in%20the%20'...'%20option%20(Teams%20left%20panel).%20I%20guess%20this%20is%20the%20problem%2C%20but%20why%20I%20see%202%20apps%20after%20a%20single%20installation%3F%20I%20install%20with%20App%20Studio%20(Test%20%26amp%3B%20Distribute%20-%20Install%20-%20Add%20to%20a%20team)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1163394%22%20slang%3D%22en-US%22%3ERe%3A%20Compose%20Extension%3A%20One%20command%2C%20displayed%20twice%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1163394%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F402611%22%20target%3D%22_blank%22%3E%40diegoSpace%3C%2FA%3E%26nbsp%3BPlease%20remove%20the%20multiple%20instances%20of%20the%20app%20and%20try%20it.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi,
I have a custom application in Teams, with a bot running. I use App Studio for the creation process.

I have added a Messaging extension with 1 command and 1 param (to test this functionality), with 'Compose Box' option selected.

My problem is I see twice the command when I open 'What can I do?' in Teams client.

In the manifest there is only one command in the composeExtensions vector.

Where can be the problem?


Thanks in advance,
Diego

3 Replies

@diegoSpace Could you please check if you have installed multiple instances of the app in other teams, delete them and have a single instance.

@Gousia_Begum I have installed this app only in one team, but i do see the application twice in the '...' option (Teams left panel). I guess this is the problem, but why I see 2 apps after a single installation? I install with App Studio (Test & Distribute - Install - Add to a team)

 

Thanks

@diegoSpace Please remove the multiple instances of the app and try it.