Microsoft Tech Community Live:  Microsoft Teams Edition
November 09, 2021, 08:00 AM - 12:00 PM (PST)

Collaborating on MST Third Party App Development

%3CLINGO-SUB%20id%3D%22lingo-sub-1602494%22%20slang%3D%22en-US%22%3ECollaborating%20on%20MST%20Third%20Party%20App%20Development%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1602494%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20messaging%20extension%20and%20conversational%20bot%20in%20development%20for%20Microsoft%20Teams%2C%20I%20am%20handing%20the%20work%20off%20to%20another%20dev%20but%20am%20having%20trouble%20with%20the%20server.%20I%20can%20run%20the%20server%20locally%20without%20any%20problem%2C%20and%20when%20I%20am%20running%20it%2C%20everyone%20with%20the%20manifest%20can%20use%20the%20third%20party%20app.%20However%2C%20when%20the%20server%20and%20local%20tunneling%20is%20running%20off%20of%20another%20computer%20other%20than%20my%20own%20the%20app%20doesn't%20work.%20I%20believe%20it%20has%20something%20to%20do%20with%20the%20something%20on%20azure%2C%20but%20I%20don't%20fully%20understand%20what%20needs%20to%20be%20done%20there.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1602494%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1607469%22%20slang%3D%22en-US%22%3ERe%3A%20Collaborating%20on%20MST%20Third%20Party%20App%20Development%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1607469%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F714579%22%20target%3D%22_blank%22%3E%40marcusyoung%3C%2FA%3E%2C%26nbsp%3Blooks%20like%20either%20bot%20is%20not%20created%20properly%20or%20hosting%20issue.%20Follow%20the%20steps%20mentioned%20in%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fbot-service%2Fbot-builder-tutorial-basic-deploy%3Fview%3Dazure-bot-service-4.0%26amp%3Btabs%3Dcsharp%252Cvs%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Edocument%3C%2FA%3E%20to%20create%20and%20deploy%20your%20bot.%20Let%20me%20know%20if%20you%20are%20still%20facing%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have a messaging extension and conversational bot in development for Microsoft Teams, I am handing the work off to another dev but am having trouble with the server. I can run the server locally without any problem, and when I am running it, everyone with the manifest can use the third party app. However, when the server and local tunneling is running off of another computer other than my own the app doesn't work. I believe it has something to do with the something on azure, but I don't fully understand what needs to be done there.

1 Reply

@marcusyoung, looks like either bot is not created properly or hosting issue. Follow the steps mentioned in document to create and deploy your bot. Let me know if you are still facing issue.