Cannot get meeting info if meeting is created on outlook

Brass Contributor

Hi, I created a meeting on teams and I can get meeting info with meeting join url. However if I create a meeting on outlook and I try to use same way to get meeting info, I will receive following error response: 

    "error": {
        "message""An error has occurred.",
        "innerError": {

On last month I created meetings on outlook and It worked but now it fails. Can you check why I was forbidden (I had access token generated by azure bot) and whether the users can get meeting info if a meeting is created on outlook? Thanks

8 Replies

We have created meeting in Outlook and call the graph below graph api.
GET /me/onlineMeetings?$filter=JoinWebUrl%20eq%20'{joinWebUrl}'
But we are getting meeting info.






I tried again and it doesn't work on me, This is the request and response I have


Could you check the request id? Thanks

@ChenguangHe - Have you created an application access policy and granted it to a user to authorize the app configured in the policy to fetch online meetings and/or online meeting artifacts on behalf of that user (with user ID specified in the request path)?
Please refer below doc to Configure application access to online meetings :
@Nivedipa-MSFT I confirm that I have the access policy. Because I can get meeting info if it is created on teams

@ChenguangHe - We have tested this in postman, but we are able to get meeting info of online meeting which is created in outlook.



Could you please create new meeting in outlook and check once again? Please follow below steps:
1. Create meeting in outlook.

2. Create application policy for online meeting.
New-CsApplicationAccessPolicy -Identity Test-policy -AppIds "ddb80e06-92f3-4978-bc22-a0eee85e6a9e", "ccb80e06-92f3-4978-bc22-a0eee85e6a9e", "bbb80e06-92f3-4978-bc22-a0eee85e6a9e" -Description "description here"

3. Grant policy to user
Grant-CsApplicationAccessPolicy -PolicyName Test-policy -Identity "748d2cbb-3b55-40ed-8c34-2eae5932b22a"

4 Grant policy to whole tenant
Grant-CsApplicationAccessPolicy -PolicyName Test-policy -Global

5 Get authentication token. Please refer below document for getting token.
Get access without a user - Microsoft Graph | Microsoft Learn

6. Execute below API in Postman.
GET /me/onlineMeetings?$filter=JoinWebUrl%20eq%20'{joinWebUrl}'

Could you please test this API in graph explorer also?

@ChenguangHe - Could you please confirm is your issue resolved or are you still facing this issue?
Hi @Nivedipa-MSFT I didn't done anything and the problem is solved. I don't know what happened

@ChenguangHe - Glad to hear that your issue is resolved. Could you please share your valuable feedback via Microsoft Teams Developer Community Response Feedback.