Bug? app catalog seems to be broken after many install/uninstall's of test app, no longer installs

Occasional Contributor

I have been uploading my own app to our organization and removing it multiple times via the POST /appCatalogs/teamsApps endpoint then removing it via the Teams admin portal.


After a while I would get an error in the Teams admin portal when I tried to remove it from the App Catalog. Eventually it would work itself out. (Error screen captured in attached image)


Now the application does not show up in the Teams admin app catalog portal, or via calling GET /appCatalogs/teamsApps. BUT I get a 400 error when trying to upload the same app manifest file that succeeded before AND after manually uploading the manifest zip file into teams, teams stalled for a bit but now shows the app icon without the image. The application still is not listed in our catalog.


Since this is still under development I tried to change the App ID and continue on, but this had the same result.


In my developer instance of Teams, the app still shows in the Teams admin app catalog portal, but attempting to delete it results in an error. The app also does not show up when trying the endpoint GET /appCatalogs/teamsApps. 


Is this a bug internally to Microsoft?

UPDATE: I made another completely different barebones test app with the App Studio and I get the same 400 error when attempting to POST /appCatalogs/teamsApps


3 Replies

@adamhouck , Could you please provide us the manifest so we can test it at our end?

@Trinetra-MSFT sure, please see the attached file. 


Just to clarify the manifest seems to install fine manually, its just when using

POST https://graph.microsoft.com/v1.0/appCatalogs/teamsApps
Content-type: application/zip
Content-length: {size}

[Zip file containing a Teams app package]

That seems to create issues.

Good news, after manually reinstalling the application and using the Graph API endpoints to uninstall then remove it from the app catalog I was able to clear out the references to it and now it installs again.

It still shows up in the app catalog in admin.teams.microsoft.com, and throws an error when you try to click delete, but I that doesn't matter to me.