Troubleshooting PXE/TFTP/Required Deployments that sporadically don't work

New Contributor

I am automating Task Sequence testing by making Required Deployments for temporary Task Sequences in temporary Device Collections for temporary VMware virtual machines.


I have a problem in that 25-50% of the time the virtual machine will not get load the boot image and start the Require Deployment and it enters the boot menu. Usually a reboot will make the virtual machine try again successfully, but not always.


For deployments that don't start to load the boot image, I can see from the logs that the MAC is a match and that the correct Task Sequence is being offered, but no TFTP connections start.


Some facts:

* SCCM PXE Responder - but I have tried with WDS with the same result. PXE Responder has better logs.

* IP Helper to Distribution Point with SCCM PXE Responder

* MAC, device collection, Task Sequence are always unique.

* DHCP Delay at 100ms (saw it in a different thread, but it hasn't helped)

* Tried both E1000e and VMXNet3

* Changed TFTP Window Size to 4 and Block Size to 1456 (which seems to be what VMware prefers or can handle)


Is there any way I can figure out why I can't get a 100% successful result in getting devices to load the boot image and start the required task sequence?


Thanks for any pointers in turning on verbose logging or any other helpeful tips.


1 Reply
best response confirmed by EGraa (New Contributor)

Was able to circumvent this issue by adding a retry on failed boot parameter on my VMware VMs.