Software Centre Application "not applicable"

%3CLINGO-SUB%20id%3D%22lingo-sub-2980659%22%20slang%3D%22en-US%22%3ESoftware%20Centre%20Application%20%22not%20applicable%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2980659%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3EWe%20have%20an%20application%20deployed%20via%20SCCM%20to%20a%20user%20based%20collection.%3C%2FP%3E%3CP%3EThe%20application%20appears%20to%20have%20no%20requirements%20or%20supersedence%20etc%3C%2FP%3E%3CP%3EFor%20the%20vast%20majority%20of%20users%20installing%20this%20via%20Software%20Centre%20is%20fine.%3C%2FP%3E%3CP%3EThis%20is%20an%20AppV%20package.%3C%2FP%3E%3CP%3EFor%20a%20subset%20of%20users%20when%20trying%20to%20install%20via%20Software%20Centre%2C%20it%20shows%20an%20error%20saying%20%22this%20software%20is%20not%20applicable%20to%20your%20device%22%3C%2FP%3E%3CP%3EIn%20the%20SCClient%20log%20it%20shows%3A%3C%2FP%3E%3CP%3EApplicabilityState%20%3D%20%22Unknown%22%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20if%20I%20log%20on%20to%20the%20same%20PC%20as%20another%20user%20also%20in%20the%20collection%2C%20it%20works%20just%20fine%2C%20so%20presume%20some%20user%20type%20issue%3F%3CBR%20%2F%3EBut%20there%20is%20no%20discernible%20difference%20between%20the%20users.%20I%20thought%20maybe%20roaming%20profiles%20might%20be%20an%20issue%20but%20I've%20tried%20on%20a%20user%20with%20a%20roaming%20profile%20and%20it%20works.%3C%2FP%3E%3CP%3EI%20can't%20see%20much%20else%20in%20the%20logs%20as%20to%20what%20to%20check.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20on%20what%20could%20be%20wrong%20please%3F%20Or%20where%20else%20to%20look%20for%20errors%20or%20causes%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi there,

We have an application deployed via SCCM to a user based collection.

The application appears to have no requirements or supersedence etc

For the vast majority of users installing this via Software Centre is fine.

This is an AppV package.

For a subset of users when trying to install via Software Centre, it shows an error saying "this software is not applicable to your device"

In the SCClient log it shows:

ApplicabilityState = "Unknown";

 

However, if I log on to the same PC as another user also in the collection, it works just fine, so presume some user type issue?
But there is no discernible difference between the users. I thought maybe roaming profiles might be an issue but I've tried on a user with a roaming profile and it works.

I can't see much else in the logs as to what to check.

 

Any ideas on what could be wrong please? Or where else to look for errors or causes?

0 Replies