DPM 2019 does not recognize protected SQL Server version after upgrade

New Contributor

Hi,

we have upgraded DPM 2019 protected SQL Server from 2016 to 2017 in-place (not SQL hosting DPM database, but SQL we are protecting with). Protection works but DPM still saying that auto-protection failed.

 

I have looking into logs and see that DPM is still querying SQL version 2016 instead of 2017 over WMI. It didn't recognized that SQL was upgraded and Refresh in protection group showing same error regarding WMI.

 

I have figured it through Process Monitor and saw wmiprvse.exe asking for following path

HKLM\SOFTWARE\Microsoft\Wbem\CIMOM\SecuredHostProviders\ROOT\Microsoft\SqlServer\ComputerManagement13:__Win32Provider.Name="MSSQL_ManagementProvider"

but it should be

HKLM\SOFTWARE\Microsoft\Wbem\CIMOM\SecuredHostProviders\ROOT\Microsoft\SqlServer\ComputerManagement14:__Win32Provider.Name="MSSQL_ManagementProvider"

I have tried to remove all backups, uninstall agent, install again and add targets, but wmi error keeps showing.

 

In DPM agent logs is

0778 2734 12/06 12:10:43.764 03 wmiqueryhelper.cpp(145) [00000069D6E7EC60] FA6F4362-B271-46FC-9120-54A46E9F8755 WARNING Failed: Hr: = [0x80041013] : unable to execute the WQL query: SELECT * FROM ServerSettings
0778 2734 12/06 12:10:43.764 61 sqlmirroringhelper.cpp(175) [00000069D6E7F260] FA6F4362-B271-46FC-9120-54A46E9F8755 WARNING Failed: Hr: = [0x80041013] : Encountered Failure: : lVal : wmiQueryHelper.ExecuteWQLQuery(ssWMIQuery)
0778 2734 12/06 12:10:43.764 61 sqlmirroringhelper.cpp(81) [00000069D6E7F260] FA6F4362-B271-46FC-9120-54A46E9F8755 WARNING Failed: Hr: = [0x80041013] : unable to get instance names from sql 2016 wmi: lVal : GetInstanceNamesFromWMI(ssWMINamespace, arrLocalInstanceNames)

 

Is it possible somehow manually update protected SQL Server version from 2016 to 2017 in DPM 2019? In database or any file or registry?

 

Edit: I have figured out that not just upgraded SQL Server has a problem but if we installed agent on another server where is also SQL Server 2017 and another has SQL Server 2019, we are getting same WMI errors for them. So basically all SQL Servers higher than v2016 has WMI problem.

 

Thanks

2 Replies
I have same problem. Upgraded sql from 2016 to 2019. my dpm looks for version 10 and 14, failing in wmi. but i have wmi populated with 13 and 15. Autoprotection seems to fail. i have DPM 2019 RTM, might try updating it first with some RU.
Just a hint, I reinstalled back to the SQL server these SQL 2016 components:
Client Tools Connectivity
Client Tools SDK
Client Tools Backward Compatibility
And now DPM discovery works. I did uninstall all 2016 stuff from server after the instances were upgraded to 2019 version. Seems DPM agent did not notice this part and keeps using 2016 tools for discoveries.
It is worth someone from MS to probably hotfix this.

Now all is green and I do not really mind those 2016 tools on the server.

PS: I also updated DPM2019 to RU3, but that did not help originally.