Sway link for sharing not changing when i switch from organisation only to anyone with a link

%3CLINGO-SUB%20id%3D%22lingo-sub-2106255%22%20slang%3D%22en-US%22%3ESway%20link%20for%20sharing%20not%20changing%20when%20i%20switch%20from%20organisation%20only%20to%20anyone%20with%20a%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2106255%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20trying%20to%20share%20my%20sway%20with%20%22anyone%20with%20a%20link!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIts%20default%20stuck%20on%20%22anyone%20within%20my%20organisation%22%20and%20when%20I%20select%20anyone%20with%20a%20link%2C%20the%20link%20doesn't%20update%20or%20change.%20When%20I%20send%20it%20to%20others%20they%20are%20asked%20to%20sign%20in.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2106255%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESway%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2127638%22%20slang%3D%22en-US%22%3ERe%3A%20Sway%20link%20for%20sharing%20not%20changing%20when%20i%20switch%20from%20organisation%20only%20to%20anyone%20with%20a%20link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2127638%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F946188%22%20target%3D%22_blank%22%3E%40mrbennet%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EShort%20answer%3A%20Make%20a%20duplicate%20of%20the%20Sway%2C%20change%20the%20share%20preference%20to%20%22Anyone%20with%20a%20link%22%20and%20share%20the%20new%20version%20instead.%20That%20at%20least%20solves%20it%20for%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELonger%20answer%3A%20I%20have%20the%20same%20issue.%20I%20make%20a%20weekly%20Sway%20as%20a%20sort%20of%20newsletter.%20When%20I%20change%20the%20share%20setting%20to%20%22Anyone%20with%20the%20link%22%20and%20refresh%20the%20tab%20in%20my%20browser%2C%20it%20has%20been%20switched%20back%2For%20somehow%20Sway%20has%20not%20recognized%20or%20saved%20the%20change.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20feels%20like%20this%20only%20happens%20with%20Sways%20that%20I%20work%20on%20for%20a%20longer%20period%20of%20time.%20For%20example%20if%20I%20create%20a%20new%20Sway%20on%20a%20Monday%2C%20as%20to%20gradually%20fill%20it%20with%20content%20by%20it's%20Friday%20deadline.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20switching%20browsers%20and%20logging%20in%20and%20out%20of%20my%20account%2C%20but%20the%20only%20solution%20seems%20to%20be%20the%20one%20at%20the%20top%20here.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I'm trying to share my sway with "anyone with a link! 

 

Its default stuck on "anyone within my organisation" and when I select anyone with a link, the link doesn't update or change. When I send it to others they are asked to sign in. 

2 Replies

Hi @mrbennet,

 

Short answer: Make a duplicate of the Sway, change the share preference to "Anyone with a link" and share the new version instead. That at least solves it for me.

 

Longer answer: I have the same issue. I make a weekly Sway as a sort of newsletter. When I change the share setting to "Anyone with the link" and refresh the tab in my browser, it has been switched back/or somehow Sway has not recognized or saved the change.

 

It feels like this only happens with Sways that I work on for a longer period of time. For example if I create a new Sway on a Monday, as to gradually fill it with content by it's Friday deadline.

 

I have tried switching browsers and logging in and out of my account, but the only solution seems to be the one at the top here.

Thank you! i'll give this a try next time. This time I got it working by switching to my phone and resharing the link from that device instead. @aleksanderbatnes