White Board app stuck on signing you in screen. Windows 10 for Teams.

Occasional Contributor

I have 63 hubs on campus, maybe one of them gets past the white board sign in screen. I've uninstalled/reinstalled white board, checked for updates, uninstalled/reinstalled Teams. None of my usual hub fixes are working on this. I'm opening up a ticket with Microsoft, but was hoping anyone else had any ideas or other fixes I can try.

6 Replies

@jmarquez I'm suddenly getting the same result on every one of the Surface Hubs I've tried in my organization...we have nearly 200. Same as you, I've reset the app and tried all the other usual remedies but nothing has changed. I'm going to have to open a ticket with Microsoft as well.

Good luck with the ticket, the person on MS side wants me to list all of the serial numbers for the hubs that are having issues.....I'm more like why don't we get one working then we can worry about the others. I was looking to see if a bad update came through, but as I was going through the update logs I saw no recent update. I am going to do a wipe on the one I have here for testing. I'll fill you in on how that worked out.

@jmarquez The MS rep I spoke to verified that it was a bug in the Whiteboard app and they released a newer version early this afternoon CDT to address it. Endpoint Manager is automatically pushing the update for me, but I was also able to manually update by opening the Microsoft Store and then going to the Microsoft Whiteboard product page. This results in app version 21.10405.5658.0 being installed which solved the issue for me. Good luck!

Hello everyone,


@JesseYWilliams is correct, the Whiteboard app version that resolves this is 21.10405.5658.0

Please check if this is installed and working. If not, check for Windows Store updates if you have a previous build. 


Best regards,


Yep, just got my answer. Wow, a two day turn around time! What amazing times we are living in!
This is now happening to our Surface hub V1 after uninstalling the Microsoft Surface Whiteboard. Just sits at the Sign In screen. Tried reinstalling it and nothing. Unfortunatly the store is only offering its version 52 and not the 21 - what can i do!?!?