Surface HUB unable to send emails

%3CLINGO-SUB%20id%3D%22lingo-sub-389245%22%20slang%3D%22en-US%22%3ESurface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389245%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20having%20issue%20emailing%20attachments%20out%20from%20our%20surface%20hub.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20the%20whiteboard%20application%20when%20we%20select%20'Share'%20-%26gt%3B%20'Email'%20and%20completed%20the%20process%20by%20filling%20in%20the%20receivers%20email%20address%20and%20Click%20'Send'%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20appear%20to%20us%20that%20the%20email%20has%20been%20sent%2C%20we%20are%20not%20getting%20any%20error%20message%20as%20such.%20But%20no%20email%20received%20by%20the%20recipient.%20We%20did%20a%20trace%20via%20Office%20365%20no%20records%20of%20email%20being%20send%20out%20from%20the%20surface%20hub%20email%20address%20nor%20was%20there%20any%20emails%20being%20quarantine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestion%20what%20may%20have%20been%20the%20issue%20for%20us%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-389889%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389889%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F299103%22%20target%3D%22_blank%22%3E%40WesHutchison%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20believe%20this%20needs%20to%20be%20investigated.%20Please%20open%20a%20case%20to%20assist%20further.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThank%20you%2C%3C%2FP%3E%0A%3CP%3ECezar%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-389807%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389807%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F230414%22%20target%3D%22_blank%22%3E%40Cezar%20Cretu%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20a%20command%20for%20on%20premise%20Skype%20For%20Business.%20We%20use%20Exchange%20and%20SFB%20online%20only.%20It%20is%20an%20unrecognized%20command.%3C%2FP%3E%3CP%3EWhen%20we%20initially%20tried%20to%20connect%20the%20SurfaceHUb%20it%20complained%20about%20Exchange%20active%20Sync%20not%20being%20reachable.%20However%20i%20know%20this%20does%20work.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-389253%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389253%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPlease%20check%20if%20anonymous%20emails%20are%20disabled%20as%20described%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsurface-hub%2Fon-premises-deployment-surface-hub-device-accounts%23disable-anonymous-email-and-im%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehere.%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EOtherwise%2C%20this%20needs%20further%20investigation%20and%20log%20analysis%20so%20if%20it's%20the%20case%2C%20please%20open%20a%20Support%20Request%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F4037644%2Fsurface-contact-surface-warranty-and-software-support%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehere.%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThank%20you%2C%3C%2FP%3E%0A%3CP%3ECezar%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1017803%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1017803%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F299103%22%20target%3D%22_blank%22%3E%40WesHutchison%3C%2FA%3E%26nbsp%3Bwere%20you%20able%20to%20resolve%20this%20issue%3F%20I'm%20having%20the%20same%20thing.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1019340%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1019340%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F206637%22%20target%3D%22_blank%22%3E%40Joel%20Gonzalez%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEventually%20yes.%20I%20logged%20a%20call%20with%20MS%20Support.%20Had%20to%20be%20assigned%20to%20an%20Intune%20%2F%20Azure%20AD%20expert.%20He%20found%20that%20the%20device%20was%20not%20being%20trusted%20in%20Azure%20%2F%20Intune%20even%20though%20it%20looked%20like%20it%20was.%20After%20clearing%20out%20all%20the%20old%20devices%20and%20accounts.%20We%20reconfigured%20it%20from%20scratch%20(Reset%20the%20Hub)%2C%20added%20it%20back%20into%20Azure%20as%20a%20trusted%20device%20and%20set%20the%20account%20used%20on%20the%20device%20to%20bypass%20any%20MFA.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1025096%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20HUB%20unable%20to%20send%20emails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1025096%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F299103%22%20target%3D%22_blank%22%3E%40WesHutchison%3C%2FA%3E%26nbsp%3BI%20also%20opened%20a%20ticket%20with%20MS%20support%20and%20got%20to%20the%20Surface%20Hub%20team.%20They%20determined%20that%20the%20Hub%202S%20was%20getting%20quarantined%20by%20Exchange.%20They%20provided%20me%20the%20following%20commands%20to%20determine%20if%20the%20device%20was%20blocked%20and%20then%20use%20the%20Device%20ID%20that%20was%20blocked%20to%20run%20another%20command%20and%20allow%20the%20device.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20see%20if%20a%20device%20is%20quarantined%3A%20%3CSTRONG%3EGet-MobileDevice%20-Mailbox%20'hub%40contoso.com'%20%7C%20Select%20FriendlyName%2CDeviceType%2CDeviceId%2CDeviceAccess*%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20remove%20a%20device%20from%20quarantine%3A%20%3CSTRONG%3ESet-CASMailbox%20-Identity%20'hub%40contoso.com'%20-ActiveSyncAllowedDeviceIDs%20%22DeviceIDfromAbove%22%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi All

 

We are having issue emailing attachments out from our surface hub.

 

In the whiteboard application when we select 'Share' -> 'Email' and completed the process by filling in the receivers email address and Click 'Send'

 

It appear to us that the email has been sent, we are not getting any error message as such. But no email received by the recipient. We did a trace via Office 365 no records of email being send out from the surface hub email address nor was there any emails being quarantine.

 

Any suggestion what may have been the issue for us here?

6 Replies

Hello,

 

Please check if anonymous emails are disabled as described here.

Otherwise, this needs further investigation and log analysis so if it's the case, please open a Support Request here. 

 

Thank you,

Cezar

@Cezar Cretu 

 

This is a command for on premise Skype For Business. We use Exchange and SFB online only. It is an unrecognized command.

When we initially tried to connect the SurfaceHUb it complained about Exchange active Sync not being reachable. However i know this does work.

@WesHutchison 

 

I believe this needs to be investigated. Please open a case to assist further.

 

Thank you,

Cezar

@WesHutchison were you able to resolve this issue? I'm having the same thing.

@Joel Gonzalez 

 

Eventually yes. I logged a call with MS Support. Had to be assigned to an Intune / Azure AD expert. He found that the device was not being trusted in Azure / Intune even though it looked like it was. After clearing out all the old devices and accounts. We reconfigured it from scratch (Reset the Hub), added it back into Azure as a trusted device and set the account used on the device to bypass any MFA.

 

 

@WesHutchison I also opened a ticket with MS support and got to the Surface Hub team. They determined that the Hub 2S was getting quarantined by Exchange. They provided me the following commands to determine if the device was blocked and then use the Device ID that was blocked to run another command and allow the device.

 

To see if a device is quarantined: Get-MobileDevice -Mailbox 'hub@contoso.com' | Select FriendlyName,DeviceType,DeviceId,DeviceAccess*

 

To remove a device from quarantine: Set-CASMailbox -Identity 'hub@contoso.com' -ActiveSyncAllowedDeviceIDs "DeviceIDfromAbove"