SOLVED

Surface Hub not updating in Microsoft Intune

%3CLINGO-SUB%20id%3D%22lingo-sub-170086%22%20slang%3D%22en-US%22%3ESurface%20Hub%20not%20updating%20in%20Microsoft%20Intune%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-170086%22%20slang%3D%22en-US%22%3E%3CP%3E%3CEM%3EI've%20also%20x-post%20this%20to%20the%20Intune%20community%20too%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Intune%2FSurface-Hub-not-updating-in-Microsoft-Intune%2Fm-p%2F170087%23M554%22%20target%3D%22_blank%22%3Ehere%3C%2FA%3E%2C%20but%20thought%20I'd%20also%20post%20here.%3C%2FEM%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIs%20anyone%20using%20Microsoft%20Intune%20to%20manage%20their%20Surface%20Hubs%2C%20and%20have%20any%20of%20you%20had%20any%20issues%20since%20the%20February%202018%20CU%20was%20deployed%20(15063.909)%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20enrolled%20my%20test%20Surface%20Hub%20while%20it%20was%20on%20the%20January%20CU%20(15063.850)%20and%20it%20was%20working%20fine.%20Configurations%20were%20being%20delivered%20and%20hardware%20inventory%20was%20being%20polled%20and%20retrieved%20from%20the%20device.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThen%20the%20February%20CU%20came%20out%20and%20was%20installed.%20Now%20my%20test%20Surface%20Hub%20isn't%20updating%20anything.%20I've%20installed%20the%20March%20CU%20that%20came%20out%20yesterday%20(15063.936)%20and%20it's%20still%20not%20sending%20anything%20new%20back%20or%20installing%20new%2Fchanged%20configurations.%20However%2C%20the%20Surface%20Hub%20says%20that%20it's%20checked%20in%20fine%2C%20and%20Intune%20is%20updating%20the%20last%20check-in%20time%20correctly.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20first%20batch%26nbsp%3Bof%20Surface%20Hubs%20that%20I%20since%20enrolled%20(15%20of%20the%2035%20we%20have)%20are%20all%20showing%20the%20same%20signs%20too%20(mixture%20of%20Feb%20and%20March%20CU%20installed)%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3EHardware%20inventory%20not%20being%20retrieved%3C%2FLI%3E%0A%3CLI%3EApplication%20inventory%20not%20being%20retrieved%3C%2FLI%3E%0A%3CLI%3EConfigurations%20not%20being%20deployed%3C%2FLI%3E%0A%3CLI%3ECompliance%20not%20being%20evaluated%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CP%3EI%20have%20an%20open%20case%20with%20Premier%20Support%20and%20we're%20looking%20into%20it%2C%20but%20I%20was%20wondering%20if%20anyone%20else%20has%20seen%20this%20behaviour%20since%20the%20Feb%20CU%20came%20out%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-187952%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20Hub%20not%20updating%20in%20Microsoft%20Intune%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-187952%22%20slang%3D%22en-US%22%3EHi%20Stefan%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20it%20turned%20out%2C%20for%20us%20at%20least%2C%20that%20the%20cause%20was%20applying%20our%20Windows%2010%20device%20compliance%20policy%20to%20the%20Surface%20Hubs.%20Supposedly%20Intune%20can't%20currently%20process%20the%20compliance%20requirements%2C%20and%20it%20in%20turn%20causes%20Intune%20to%20stop%20processing%20the%20Surface%20Hub%20hardware%20inventory%20properly%2C%20or%20applying%20configurations%20to%20the%20device.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20was%20told%20last%20week%20to%20expect%20an%20imminent%20update%20into%20Intune%20to%20support%20user-less%20devices%2C%20Such%20as%20Surface%20Hub%2C%20with%20compliance%20policies...%20and%20lo%20and%20behold%20it%20has%20appeared%20in%20this%20week's%20update%20in%20What's%20New!%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-gb%2Fintune%2Fwhats-new%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-gb%2Fintune%2Fwhats-new%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%3CBR%20%2F%3ED%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-187337%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20Hub%20not%20updating%20in%20Microsoft%20Intune%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-187337%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F30238%22%20target%3D%22_blank%22%3E%40Daniel%20Hudson%3C%2FA%3EDo%20you%20have%20an%20update%20on%20this%20issue%20with%20Microsoft%20Support%3F%26nbsp%3B%3C%2FP%3E%3CP%3ELooks%20like%20we%20are%20experiencingthe%20same%20issue.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooking%20forward%20to%20hear%20from%20you.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-176333%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20Hub%20not%20updating%20in%20Microsoft%20Intune%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-176333%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Mik%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAttached%20is%20just%20a%20small%20snip%20of%20the%2035%2B%20Surface%20Hubs%20we%20have%20enrolled%20with%20Intune.%20As%20you%20can%20see%2C%20some%20aren't%20reporting%20anything%2C%20some%20are%20incorrectly%20reporting%20compliance%20status%2C%20and%20one%20is%20still%20showing%20it's%20on%20the%20January%20CU%20(15063.909)%20rather%20than%20the%20March%20CU%20(15063.966)%20when%20I%20know%20it%20has%20it%20installed.%20Also%2C%20as%20you%20can%20see%2C%20they've%20all%20checked%20in%20within%20the%20last%2010%20hours.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI'm%20now%20seeing%20most%20of%20them%20receiving%20a%20Default%20Device%20Compliance%20Policy%20which%20I%20haven't%20created%2Fset%2C%20suggesting%20something%20is%20up%20with%20these%20in%20Intune%20in%20a%20big%20way%20right%20now...%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ED%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-176270%22%20slang%3D%22en-US%22%3ERe%3A%20Surface%20Hub%20not%20updating%20in%20Microsoft%20Intune%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-176270%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20I'm%20definitely%20seeing%20something%20similar%20on%20the%20hubs%20I've%20enrolled%20in%20intunes.%3C%2FP%3E%0A%3CP%3EThey%20are%20getting%20quality%20updates%20but%20not%20feature%20updates.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHow%20do%20you%20see%20the%20extended%20version%20of%20the%20Surface%20Hub%3F%20build%2015063.xxxx%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Super Contributor

I've also x-post this to the Intune community too here, but thought I'd also post here.

 

Is anyone using Microsoft Intune to manage their Surface Hubs, and have any of you had any issues since the February 2018 CU was deployed (15063.909)?

 

I enrolled my test Surface Hub while it was on the January CU (15063.850) and it was working fine. Configurations were being delivered and hardware inventory was being polled and retrieved from the device.

 

Then the February CU came out and was installed. Now my test Surface Hub isn't updating anything. I've installed the March CU that came out yesterday (15063.936) and it's still not sending anything new back or installing new/changed configurations. However, the Surface Hub says that it's checked in fine, and Intune is updating the last check-in time correctly.

 

The first batch of Surface Hubs that I since enrolled (15 of the 35 we have) are all showing the same signs too (mixture of Feb and March CU installed):

 

  • Hardware inventory not being retrieved
  • Application inventory not being retrieved
  • Configurations not being deployed
  • Compliance not being evaluated

I have an open case with Premier Support and we're looking into it, but I was wondering if anyone else has seen this behaviour since the Feb CU came out?

4 Replies

Yes I'm definitely seeing something similar on the hubs I've enrolled in intunes.

They are getting quality updates but not feature updates.

 

How do you see the extended version of the Surface Hub? build 15063.xxxx

 

 

Hi Mik

 

Attached is just a small snip of the 35+ Surface Hubs we have enrolled with Intune. As you can see, some aren't reporting anything, some are incorrectly reporting compliance status, and one is still showing it's on the January CU (15063.909) rather than the March CU (15063.966) when I know it has it installed. Also, as you can see, they've all checked in within the last 10 hours.

 

I'm now seeing most of them receiving a Default Device Compliance Policy which I haven't created/set, suggesting something is up with these in Intune in a big way right now...

 

D

@Daniel HudsonDo you have an update on this issue with Microsoft Support? 

Looks like we are experiencingthe same issue. 

 

Looking forward to hear from you.

best response confirmed by Daniel Hudson (Super Contributor)
Solution
Hi Stefan

So it turned out, for us at least, that the cause was applying our Windows 10 device compliance policy to the Surface Hubs. Supposedly Intune can't currently process the compliance requirements, and it in turn causes Intune to stop processing the Surface Hub hardware inventory properly, or applying configurations to the device.

I was told last week to expect an imminent update into Intune to support user-less devices, Such as Surface Hub, with compliance policies... and lo and behold it has appeared in this week's update in What's New!

https://docs.microsoft.com/en-gb/intune/whats-new

Thanks
D