Surface Hub 2S - Can't perform BMR

Copper Contributor

We're trying to deploy some Surface Hub 2S but we're having all sorts of issues. I suspect the root of the issue is they're not getting the 2020 update, but I can't find version information to check against. So I tried to do BMR using the instructions found here. I downloaded the file from the Microsoft Surface Recovery site after entering the serial number. The file downloaded is "Surface Hub 2S - Windows 10 Team 2020 Update" and the filename is


If anyone has any suggestions of what is going wrong with the BMR, I'd appreciate it. I've tried this one two different surface hubs and two different USB sticks and two different downloads of the BMR on two different PCs.


Following the instructions, I formatted a 16GB USB stick FAT32 and copied the files to the root of the drive. Then, inserting the stick into the USB-A port on the back of the Hub, power it on by holding down the volume down button and the power button. Release the power button when the windows logo appears, but continue holding the volume down button until the UI appears.

After selecting language and keyboard, it shows the screen "Choose an option: Continue or Reset" (Attempted BMR.png)

Under Reset, it gives the option for Cloud or Local. Either option produces the error "There was a problem resetting your PC." (Attempted BMR-problem.jpg)


(Sorry about no inline images, it wouldn't save)

3 Replies


Hi David, today I found your threat, having same issue as you described.
Did you found a solution for it?
thanks for reply

Hello, not sure how the USB Drive was formatted, but this is usually the problem. Please follow the steps here. Make sure to copy all unzipped files to the root of the drive and replace files if being asked to.

Thank you,

@Cezar Cretu 

it is solved. thanks for your reply.