Single Sign On Issues with 1703 Creators Update Surface Hub

Copper Contributor

Hi All, 


First Post here on the forums


We haven't had the greatest start with the Surface Hubs we purchased we had. Hopinh to turn things around :) 


We have 4 Surface Hubs


3 x 84" 

1 x 55"


The 55" works perfect absoultely from start to finish. 

Start Session --> Sign in to see user documents ---> Open Documents --> Tap Saved Sign in information and Document opens.


Start Session --> One Drive --> Open Documents-->Tap Saved Sign in information and Document opens.


All the 84" have virtually the same issue which baffles me


Start Session --> Sign in-->Open Documents -->Prompt to Sign in again with no cached credentials to be seen --> Enter Credentials Again --> Error that I dont have permission to my own document or that it may be locked. 


I've treid to Reinstall all office apps and one drive 

Tried a Recovery 

Tried Corporate and Open Wi-Fi connection (i.e. no proxy)

Logged a ticket with Microsoft - no luck yet.... has been open for a while.

Gotten a replacement HardDrive from Microsoft due to a power fault


It has become extremely fustrating and on top of that it takes about 3 mins before each session will connect to the web even though on the 55inch it will be instant. 


I have checked the Accounts of the 55 and 84 and can confirm that they are matching in system and user account OU in AD. I can only note that the 55 has a Skype account created as a user account rather than a meeting room account but I fail to see where this would cause an issue with the SSO for Office 365?


Anyone had similar issues? any feedback would be great. When working these devices are great but for us they have not.




12 Replies

Hi, A customer are havining similiar issues with there 84" surface hub. Have you any solution? /ERik

Hi Vincent

I've not seen this on our 84" Surface Hubs, though I'm intrigued that you say it's taking up to 3 minutes before they will even connect to the web on session start.

A couple of things you need to let us know to help:

- Are they joined to Azure AD, on-prem AD, or local admin?
- Are you using SfB Online or on-prem?
- What version are they running, and have they had the latest CU installed?

Something else that worries me is you say the 55" Skype account was created as a user account not a meeting room account. It sounds very much like you may have set up your accounts incorrectly. This shouldn't have an effect on O365 SSO, as the SSO credential is stored on the Surface Hub itself, but it's still sign of something that might not be happy on the Hub itself.


I am also having the same issue with our Surface Hub 55" model. I can see the documenets, but I don't have permission to the files. Also Skype for Biz doesn't work unless I reboot the surface hub first. 


Both of these issues are known bugs that Microsoft is aware of. There is no timeline to fix it. 


Surface Hub 55" On Premise AD Joined, Device Account logged in, InTune Managed, Certificates installed correctly. 

The Skype for Business problem is known ( but not in relation to the issue Vincent is talking about.

The other issue for not having permission to files is not a known issue as far as I can see.

End Session taking a long time can be linked to issues to reach Azure AD and Office 365 because we trying to clean some session and those call can be blocked if you use a proxy.

Are you using a proxy to reach the internet ?

I'm having the same issue with a 55" Surface hub.  Any known resolution yet?

Hi All


I have been working with Microsoft for the Past 6 Months on this issue


It looks like RS1 SSD's that are patched to RS2 with updates are not taking correctly


The way I have got it to work is to do the following -


Install a RS2 SSD and download updates, since this has been done it is now working


I am currently having to clone the RS2 SSD


I have had to format the RS1 SSD from the Surface Hub

Then the Clone of the RS2 SSD onto the RS1 SSD


Takes around 30 minutes to Clone the SSD and around 2 Hours to install all the updates


You will lose all configuration on the Hub and have to do the OOBE


So far I have 15 hubs to complete this on so I will be busy for the next few months


It has allowed me to now Single Sign On and provide functionality to our Users


I would recommend speaking to Microsoft and requesting a RS2 SSD and enjoy the Fun of reconfiguration


At least it is not as bad as Cloud Recovery Options





Really? Seems like MS needs to ship a 1709 with this fixed asap...

Still is not fixed. They haven't made any progress on this. I haven't been able to use my Surface Hub for demo's since I bought the freaking things. 

Any roadmap from MS to fix OP's issue? Or should we fix it manually like Max?

Microsoft are not shipping 1709 for Surface Hub.


@Jeffrey Allen mentioned it here and I have since been able to corroborate this both at the recent Tech Summit and elsewhere. Microsoft are instead looking to release features from 1709 and beyond in with the regular cumulative updates to 1703. It's less risky and allows them finer control over the content reaching Surface Hub.


No point risking features and fixes on big build updates that won't really give much to the Surface Hub experience.


While I can't give much info, it does look like a fix is in development for this specific bug, but currently no ETA on deployment except for 'soon'.


If it's a show stopper, get in touch with MS support and get a new RS2 SSD for your Surface Hub that won't have the same issue.

Hi All

It has been a major problem for us in NHS Wales for the past 6 months but it was the only solution after discussions with Microsoft Engineers and so far we have updated around 6 of our hubs with the fix and we have SSO working

I would say its worth the risk to do but depends if you have the time to do it