Scheduled meetings on Surface Hub (1703 Creators Update)

Occasional Visitor

Can anyone confirm that the 'see my scheduled meetings' functionality doesn't work with Exchange on premise mailboxes?

12 Replies

I knew I saw a thread about this somewhere, and I was right! It's here!


I'm not sure if MS have fixed the localisation bug yet, but in short if your Surface Hub isn't set to en-us, you're going to have a bad time.


Also, it appears that it only works for Exchange Online (or Hybrid) configurations. If you're fully on-prem, you're going to have a bad time.

Hi Daniel,



First of all, thanks for the quick reply!


Our Surface hubs are already set to US-English so no luck there.

We have however Exchange on prem (full) so I'm guessing our problem lies there.

I already saw the post in your link but I was looking for an official confirmation of Microsoft that this issue by design. Just so I could communicate this to our customers.


I was also looking for an indication that this issue was solved in the 1709 Fall Update but also, no luck there.





I am having the same issue on Hub 2 with Exchange On-prem accounts and it is nearly 2 years later.

Is this still an known issue?  Is there a fix or is Microsoft forcing to Exchange Online?

Hello @Chris_Gates,


This will not be fixed as it's not broken.

The option to see your scheduled meetings relies on Graph Explorer which pulls the calendar information from Office 365. This, as you can imagine, will not work with Exchange on-premises and currently there is no plan to implement it. 


Thank you,


@Cezar Cretu That's absolutely worthless, so I'm forced to migrate my users to the cloud to be able to actually retrieve my meetings on the Surface Hub so I can join the meeting as the person who's logged in.


Because that's the only way to join a meeting using the Surface Hub if the meeting has been created by a 3rd party company 


Because the join meeting button by using a room device is not available on their phones or any device when the invite is from outside the company. There's no use "Room Device" button available, the interface is different.


The only option I have right now is always ensuring that our users create the meeting on our side and invite the Surface Hub.

Or the 3rd party invites the room in their invitation(Which is really not professional)


It's absolutely ridiculous that I'm actually forced to migrate to the cloud while currently having a perfectly working Full Hybrid situation, but this feature is essential to actually properly use the Surface Hub.





Hello @rohgin,


Retrieving your meetings and files only works with Office 365 for the reason I mentioned, you're trying to connect to a service which doesn't support this feature. 

However, this doesn't limit you from joining Teams/Skype meetings organized by users outside of your domain. You can set the device to accept external meetings using the ProcessExternalMeetingMessages parameter in the Set-CalendarProcessing cmdlet. You can also forward the meeting invite to the Surface Hub if this was not done by your partner.


Would that work for you? If not, please open a support case and we can explore all the possibilities to configure the device to work as it best makes sense for your business.


Thank you,



@Cezar Cretu 


Yeah well, we tried the invite by external party once.


They could hear us, but they couldn't see us, while the camera was definitely working. As we could see ourselves.


Restarting the Hub didn't work. They just saw the image with the 2 letters of our hub name. 


So currently we are creating the meetings to be sure everything works.


I tried forwarding, but it seems the original meeting created by the other party doesn't get the update that an user/device has been added, so there's no join button available on the Surface Hub. 

Hello @rohgin,


The video issue definitely needs to be investigated, I suggest opening a ticket with the Teams team (you can do it from the Office 365 portal).

The join button issue for forwarded meetings might be due to Windows Defender Safe Links. The Surface Hub will scan meeting invites for the Teams URL so if that is hidden, it won't show the meeting join button. Can you check how these look on the device account calendar? You can use OWA to check it.

I strongly encourage you to open a support ticket so we can resolve the issues and be happy with your Surface Hub :smile:


Thank you,




@Cezar Cretu 


I just tested the forwarding, it actually works when I send a meeting request from my on-premise user to one of our 365 accounts, next I forwarded the meeting request to the Surface Hub from the 365 user, and now it's actually showing the "Join" button.


But a friend of mine from a different organisation did send me an invite, and the original invite didn't have a join button, neither on the surface hub or my personal account where he did send the invitation to, so it's already missing on the original invitation.  I was able to use the "Join Meeting" link in the body of the calendar item, but since the surface hub isn't able to open the actual item, It's depending on the join button. Most external invitations we receive do have the Join button, but it seems that sometimes from some companies it doesn't. So normally it doesn't matter when I'm able to use the link, but since the Surface Hub is depending on the button, I can't trust to tell my users to use this method while sometimes the button is not visible on the invitation. That's just not a workable solution.


So currently I'm testing it, the guy from Microsoft did send me an invite and the join button was visible, it seems it has something to do with the time settings. so probably when the join button isn't available, it's because the person who made the invitation, didn't have the correct time settings.


Update, that wasn't the problem, I'm thinking it has something to do with OAUTH not implemented, they have a hybrid environment, I think they haven't configured OAUTH, since he told me they didn't have the calendar button on Teams yet. 

Hello @rohgin,


The meeting URL shouldn't change based on the OAUTH settings of the inviter.  As I said, the Surface Hub will scan all incoming meetings and if it finds a Teams URL it will show the Join button. 

Current investigations show that the issue might be with the Outlook client when forwarding external meetings to the Surface Hub. Can you try to forward the same meeting using OWA instead?

Or better yet, login with your credential in "My meetings and files" and try to join the call from there instead (no forward to the Hub)


Thank you,


@Cezar Cretu 

Hi Cezar,


It has nothing to do with the Hub on itself.


So company X did send me an invitation


The result:


The join button wasn't available in Teams web or desktop client, or Outlook desktop or webclient in the first place on my computer without forwarding it whatsoever.


So I've tested it with Microsoft sending me an invitation, and when they did it, the Join button was 


So, they came to the conclusion that the problem is happening on the side of the company which is inviting me. 


It's only been a handful of external companies where the join button wasn't included in the invitation.


And the problem here is that the Hub needs the join button to enter the meeting. So this makes it impossible to guarantee that forwarding will always work.


And logging in on the Surface hub and showing the meetings I've got is only available for mailboxes in the cloud. Since this is currently not an option, I want to use methods like forwarding, or directly inviting the hub. So right now we instruct our users to always invite the external companies from our side, this way we'll be a 100% sure that the hub will work.



Hello @rohgin,


Ok, I understand. The solution to invite the external companies is a good workaround for now. 

This is currently being investigated and I hope to have a definitive solution soon 


Thank you,