Microsoft Tech Community Live: Surface Edition
February 15, 2022, 08:00 AM - 12:00 PM (PST)

connecting surface hub to OMS


Last week I configured a surface hub (successfully joined to domain, on-prem mbx and SfB w/EV).  I used the ICD (Imaging and Config Designer) to push additional settings to the device after OOBE.  One of the settings is the workspace and primary key for OMS.    It looks like the settings took because when I browse to settings | device management on the hub and select OMS, the checkbox is selected and I see in yellow text "The Microsoft Monitoring Agent has successfully connected to the Azure Operational Insights service."   I also see the correct workspace ID.   What I dont see is the workspace key in the appropriate field.    (not sure if that's by design)


Looking in OMS I added the Surface Hub solution last Friday but that specific tile in OMS shows  'No Surface Hubs found'.


Can someone confirm that has their hub(s) showing up in OMS whether or not they see the workspace ID in their OMS settings on their hub?  




6 Replies

Update:     I removed the OMS config on the hub and then manually enabled OMS and entered the workspace ID and primary key.   Again it looks like the config took as I see "The Microsoft Monitoring Agent has successfully connected to the Azure Operational Insights service."  But I do not see the hub appear in the surface hub solution in OMS.


I neglected to mention in my initial post that the exchange and Skype for Business accounts are both on-prem.  Does that matter?



best response confirmed by Nydia Cavazos (Microsoft)
Hi David,
it is expected that after the join the key is will not longer be showing in the UI.
It can also take some time if you just added the Solution to OMS and added the Surface Hub to OMS. 
I don´t have an exact timeframe for this but for adding the Solution to OMS give it maybe 24h, 
adding new Surface Hub to OMS should not take longer then 1h.

For me this always just works fine and the Hubs are showing up after a short time.

If the Hubs are still not showing up, I would recommend to open a case with our CSS Support:

- Christian

My colleague Per Larsen, wrote some about here:


Hope it helps.



/Lars Berlau

I am having the same experience. Did you ever figure out what was causing this?

OMS was flaky for me until the Creators Update rolled out.  Once my Surface Hubs updated to that, every device showed up in OMS.  


IIRC, there was an issue with storing a certificate pre-Creators Update that was causing the problem.  The original workaround was to reset the device to clear the certificate store then rejoin to OMS.  Hopefully if you haven't updated to CU that will fix the issue for you.

Yup, basically this. Although I was told that the certificate had expired and they couldn't deliver a new one without pushing a new build (hence fixed in Creators Update).

Interestingly device reset never worked for us, we had to wait for the Creators Update.