Unable to import SQL Server backup using SSMS

Copper Contributor


I have just installed SQL server on my windows 10 machine and SSMS. Now I am doing the following:


1- Connecting to SSMS using windows authentication

2- Importing my SQL server backup using "Restore Database" option in SSMS.


When I select the devices by providing the SQL Server backup file details, it does not do anything. Infact the Ok button is also disabled.


I have imported the SQL server backup on the fresh installation in the past as well and it worked but not sure what I am doing wrong this time. 


Your help would be highly appreciated.

5 Replies

@waqasqadri I read the help page and it says that the user should have CREATE database access. I am connecting with default user (window authentication), using this user, if I try to create the DATABASE, I get permission denied error. I think this could be the reason its not restoring the backup.


Could you please help me in granting the admin rights to the user?

Could you please help me in granting the admin rights to the user?

@waqasqadri use SSMS GUI, edit the user => "Server role/membership"

Or see GRANT Server Permissions (Transact-SQL) - SQL Server | Microsoft Learn

Hi, Thanks for your response. I am able to resolve the issue by uninstalling and reinstalling SSMS and SQL server. Not sure why but after the reinstall, everything worked fine without any issues.

@waqasqadri I believe the problem was mostly related to permissions on the file system. Ser what happens if you run ssms as admin

Yes this could be the reason, but I ran the SSMS without admin and it worked for me. May I did something wrong somewhere.