sqlos.process_killed Extended event not firing on SQL 2019 Enterprise

%3CLINGO-SUB%20id%3D%22lingo-sub-2958382%22%20slang%3D%22en-US%22%3Esqlos.process_killed%20Extended%20event%20not%20firing%20on%20SQL%202019%20Enterprise%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2958382%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20an%20extended%20events%20session%20configured%2C%20trying%20to%20determine%20the%20T-SQL%20of%20the%20process%20being%20killed.%20But%20this%20event%20seems%20to%20never%20fire%20as%20I%20monitor%20the%20session%20in%20real-time%2C%20despite%20the%20fact%20that%20SQL%20Server%20Log%20definitely%20shows%20multiple%20SPIDs%20being%20killed.%20%26nbsp%3BCan%20anyone%20suggest%20what%20I%20am%20doing%20wrong%20here%3F%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-sql%22%3E%3CCODE%3ECREATE%20EVENT%20SESSION%20%5BKilled%5D%20ON%20SERVER%20%0AADD%20EVENT%20sqlos.process_killed(%0A%20%20%20%20ACTION(sqlserver.database_name%2Csqlserver.session_id%2Csqlserver.sql_text%2Csqlserver.username))%0AWITH%20(MAX_MEMORY%3D4096%20KB%2CEVENT_RETENTION_MODE%3DALLOW_SINGLE_EVENT_LOSS%2CMAX_DISPATCH_LATENCY%3D30%20SECONDS%2CMAX_EVENT_SIZE%3D0%20KB%2CMEMORY_PARTITION_MODE%3DNONE%2CTRACK_CAUSALITY%3DOFF%2CSTARTUP_STATE%3DON)%0AGO%3C%2FCODE%3E%3C%2FPRE%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

I have an extended events session configured, trying to determine the T-SQL of the process being killed. But this event seems to never fire as I monitor the session in real-time, despite the fact that SQL Server Log definitely shows multiple SPIDs being killed.  Can anyone suggest what I am doing wrong here?

CREATE EVENT SESSION [Killed] ON SERVER 
ADD EVENT sqlos.process_killed(
    ACTION(sqlserver.database_name,sqlserver.session_id,sqlserver.sql_text,sqlserver.username))
WITH (MAX_MEMORY=4096 KB,EVENT_RETENTION_MODE=ALLOW_SINGLE_EVENT_LOSS,MAX_DISPATCH_LATENCY=30 SECONDS,MAX_EVENT_SIZE=0 KB,MEMORY_PARTITION_MODE=NONE,TRACK_CAUSALITY=OFF,STARTUP_STATE=ON)
GO
0 Replies