SQL Server installer unable to download the required files

Occasional Visitor

Dear Community,

I wanted to install the developer edition, however, I keep getting this error message:

"We failed to download the files we require. Please check your network connection and try again."install.PNG

 

 

My network connection is working fine; however, my local disk is almost full. If that's the reason the installer is failing, is it possible to force it to download to another disk?

 

Thanks.

42 Replies

I found I was getting the below error in event viewer (Along with the error OP is seeing) at each attempt to install SQL server Dev edition or express.

 

Addition Error: "A fatal error occurred while creating a TLS client credential. The internal error state is 10013."

 

Here are the steps (from at this post) I used:

 

 

1. In Control Panel, click Administrative Tools, and then double-click Local Security Policy.

 

2. In Local Security Settings, expand Local Policies, and then click Security Options.

 

3.Under Policy in the right pane, double-click System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing, and then click Enabled.

 

4. Ran gpupdate /force 


Thank you,
Aaron.

 

I corrected the error by enabling TLS 1.0.

@Michael Yusko Still happening in 2020, even with TLS 1.2

Succeeded by opening Telerik Fiddler and then started the SQL Server installation.

 

I've had a similar problem with SQL Express 2019 and this helped on WS 2019

 

# set strong cryptography on 64 bit .Net Framework (version 4 and above)
Set-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type Dword
# set strong cryptography on 32 bit .Net Framework (version 4 and above)
Set-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type Dword
This worked for me.
Bingo!, perfect fix. You would think server 2019 would just work with this install file...

@JirkaBurian That did it for me.  Thanks!

I was installing SQL Server from the command line and my Configuration.ini file was incorrect.

 

You can check installation logs in the following path, might highlight what the issue is.

 

C:\Program Files\Microsoft SQL Server\<VERSION>\SSEI\LogFiles

 

Brilliant! Worked for Express edition too!
Is there a current fix for this? Still unable to download SQL Express or Developer server. Unfortunately, I don't really understand any of the workarounds listed in the comments

@Danthma

 

Hello,

I will tell you step by step.

 

Go to your 'Search tab' on your Windows. Open as 'administrator' 'Windows PowerShell'. You will see a blue screen whit PS C:\Windows\system32> writing in it.

 

1- Copy this and klik on enter

Set-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type Dword

 

2- Copy this and klik on enter

Set-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type Dword

 

And now you can download 'SQLServer2019'

 

 

 

 

 

 

Terrific, it worked, thank you!

@Fatih_TR 

 

Hi Faith,

 

Thank you so much for responding so quickly and provided that breakdown - looks like I was not running PowerShell as administrator initially and running into some errors. All seems to be working now. Thanks for your help on this one :smiling_face_with_smiling_eyes:

 

Dan

hi @Fatih_TR

i use your code for SQL Express
but it still no worked with my pc
hope you reply me

The same for me. Still not working. I am using Win 11 Pro (ARM Processor)

@FrankCtba 

 

Hello, i dont no what the problem could be. Because im using windows 10 pro. 


i had heard from friends that not everyrhing works great on win11

ok, actually I was trying to install Express edition. After downloading Developer edition, it worked for me. But now I am getting new errors during the install process.
Thanks!