Outlining not working in SSMS 18.x

New Contributor

In SSMS 18.x, the outlining feature that allows you to collapse SQL code often stops working, i.e. the +/- next to the code disappears and neither shortcuts or clicking in the menu will collapse code.

I have tried to uncheck outline statements in the option under intellisense and then recheck it, but that makes no difference.

Closing SSMS and restarting sometimes helps, but after a while I'm back to the same problem.

I have never had this issue in SSMS 17.x


Does anyone else have this problem, and how do you solve it?


1 Reply
I'm having this problem as well, in version 18.10 (15.0.18390.0), with SQLPrompt installed. Reopening SSMS doesn't help. Occasionally, one level of outlining will appear at the start of a stored proc script. Once the outlining submenu disappeared from the Edit menu.

I've tried altering most of the settings associated with outlining, but nothing has helped.

This is a very useful feature, and I'd really like to be able to use it.