Having a permissions issue in SQL Express

Copper Contributor

Hi All,

I am trying to fix some issues being experienced with user permissions.  I'm not sure where else I should post this question/problem for some assistance.  We are using Veeam for our backups and they are failing because the guest or Veeam account do not have permissions needed to finish the job. 


Myself and other admins have tried to add a user or change permissions in SQL Express with no luck.  We each get the error that the object doesn't exist or we don't have permission to make the change.  I'm unsure where else the object/user would need to exist since it's a functioning account in our domain.  I'm unsure which permissions are needed to make a change since this fails even with a global admin account.


I tried to follow these directions to reset the sa account password since it appears to have already been set and nobody knows the password. Once I stop/start the SQL service again and login with the single-user option, I get an error that only one admin at a time be logged in and nobody else is using it.


Searching online has basically only shown me tutorials for other problems or just adding a user after having permissions to do so.

1 Reply

I am wondering if perhaps you are administering to the Login and not the User account in the relevant database. These are 2 separate objects that are related but independent of one another. You should add the User account (in the database) to the db_backupoperator database role within the relevant database. Leave the Login account alone. I hope this is the answer you are seeking.