Error executing a SSIS package with KingswaySoft for Salesforce source from a dtexec sentence

Highlighted
Occasional Visitor

I have developed a SQl SErver 2017 package with TargetVersionin SQL Server 2012, where the data source is a KingsWaySoft for Salesforce component  and the datat destination is my SQL Server Database. If i run the package in Visual Studio it works perfectly with no errors, but if i run it from the Management Studio with a dtexec sentence, it fails.

 

If somebody can help me, i will be very apreciate. Thanks in advance.

 

I attach my scripting code and the error given from the console.

 

Scripting code:

 

declare @CADENA varchar(300)

SET @CADENA = 'C:\"Program Files (x86)"\"Microsoft SQL Server"\140\DTS\Binn\DTExec.exe /FILE "\Server\Test\Test\Test\Test.dtsx" /MAXCONCURRENT " -1 " /CHECKPOINTING OFF /REPORTING EWCDI /DECRYPT "zzzz"'

EXEC MASTER..xp_cmdshell @CADENA --,NO_OUTPUT

 

ERROR Message: Description: The connection type "Salesforce (KingswaySoft)" specified for connection manager "Salesforce" is not recognized as a valid connection manager type. This error is returned when an attempt is made to create a connection manager for an unknown connection type. Check the spelling in the connection type name. Code: 0xC0014005

1 Reply
Highlighted

Hi Manuel,


Could you make sure you have the software installed on the server you are deploying to? You will also need to request a trial license (via the KingswaySoft License Manager on the server) in order to deploy from outside of the development tools.

 

Please let us know if you have any further trouble.


Thank you,

KingswaySoft