Enable TLS 1.2 is getting me an error on SQL

Highlighted
Occasional Contributor

I have: 

Windows 2016 server

SQL server 13.x (2016)

.net framework 4.5

Visual studio 2015

 

I have the following problem:

Activating TLS 1.2 is giving me an error in SQL:

 

 

TLS1.0 image error.png

I opened SQL server 2016 version 13.x and I see the following:SQL versions.png

 

 

 

 

 

 

 

 

 

 

The SQL server is using .NET 4.0.x and I think this is the problem.

 

Can someone please help me or send me a link to fix this problem?

Thank you