a required file could not be downloaded sql server 2019 express

Occasional Contributor

Hello Everyone ,I'm trying to install SQL server 2019 Express ,but when it's downloaded and i go to Run it , the following error comes Up "a required file could not be downloaded this could mean the version of the installer is no longer supported, please download again from the download site"

i tried downloading it several times same error happened , tried deactivating Windows security also didn't work , also switched system cryptography :use FIPS compliant algorithms to enabled and that didn't work either .please help

12 Replies

@Abdellatif1995 even i am facing the same issue can anyone guide us to resolve the issue 

thank you in advance


I'm having the same issue as well.

I am also having this issue
Having this issue also, tried Dev and Express, Win 10/Win 11, no luck.

I hope MS is aware and looking at fixing this ASAP.

Has anyone had any success?
best response confirmed by Abdellatif1995 (Occasional Contributor)



Found a fix that worked for me


regedit add a Dword Value to the following 2 locations




Dword key: SchUseStrongCrypto

Value 1

it worked for me as well . thank you for sharing the solution man
For those who want the steps on how to add the Dword value . you can watch the video here for the steps in details .

@Abdellatif1995 Thank you for sharing the video I have changed the Dword value . However, I'm still getting the same error .



There must be a missing step or something , maybe try downloading the latest version of the SQL server and try again, if it doesn't work ,we can set a call on Teams or something and go through the steps one more time.  @Priyanvs324 

Hi @Abdellatif1995 i have tried the same steps and also tried windows PowerShell method as well but no use still getting the same error. I still don't get why it is not working for me.

@Abdellatif1995 finally it worked for me where I went wrong is instead of double clicking while changing the value to 1 I have right clicked and modify it :facepalm: .Now , it got installed:happyface: