Skype Room System v3.0.6.0 release notes?

New Contributor

We're running 6 Logitech SRS units and recently allowed one to perform Windows and Store updates. Noticed that the SRS app is now showing as v3.0.6.0


Anyone seen the same?

know whats new?


And whilst we're on the topic of SRS. is anyone else experiencing external display issues when runnign dual screens? ie. 'No signal' on one display?

9 Replies


the update to was afaik published at the beginning of this week. Our 2x Logitech SrSv2 got it yesterday. And there are no Release Notes available, maybe in a future we will see one.




I believe SRS v2 3.x release now has a the following new features

    themed-enabled UI, dual screen support, new OMS triggers and various bug fixes 

That was available in v3.0.0.0 and appeared mid-june only appeared last week however no idea at present what's new in it, I've deployed it to a test SRS I have setup, however can see no feature changes, guessing it's just bug fix related release?

Hi @adam rumjahn we just allowed our SRS unit to install the update (Ver when prompted (today's date: 7 Aug 2017).  Unfortunately, after the update got applied we are experiencing the issue that now only one of the two external monitors is used. (Our journey is/was: we got the logitech SRS before SRS v2 was out so only one monitor worked, then we got/applied SRS v2 and both monitors worked, now after the patch this morning only 1 monitor working)

Hi Ashley, first thing i checked was that the setting for dual screen was still enabled. Following that one of the rooms i had experiencing issues turns out that the SMART TV's are very sensitive to the refresh rate. Window's display had it set to 29hz, changing this to 60hz fixed the issue. My other issue relating to the no signal problem is possibly due to a physically damaged HDMI cable which is scheduled to be replaced (it runs behind the wall and under the floor to the conference room table).. to be confirmed shortly!

so a little update...yet another update dropped into the SRS. I started it and went home. Came back today and both screens are back in action.  I can't explain it, but we are back to 2 working screens with our Logitech SRS!

thanks for that Adam. See my reply to my own thread above.  We are back in action (it happened automagically)

can I ask what version of the SRS software you are running now? I just double checked ours and there wasn't any new updates (I guess they are not pushing them all out at once) currently running


That is correct, 

So maybe the update last night was to the OS and not the SRS software.  That's just a wild guess.  I am not very technically gifted (maybe i have other redeeming qualities ;)