Skype Room System Error skype-mrx:// class not registered

New Contributor

It appears the Surface our SRS (V2 I believe) only updated to Windows 10 1607 yesterday, which is now causing the error "Skype-mrx:// class not registered" when the Skype Room System tried to load. 


We cannot restore or uninstall the update, or see a way to upgrade to 1703 as Windows only tries to upgrade to 1709, which appears to be unsupported currently.


Does anyone know if there is a way we can resolve this error?

6 Replies

To block 1709 update set defer feature update option in Windows. Settings -> Update&Security -> Windows update tab -> Advanced options. A feature update... set to 365 days. After this update 1703 should be installed on your device. After this try to reinstall Skype Room App from store.

Hope this helps.

yesterday I've also seen this problem on two SfB Room-Systems from a customer.
The problem occured after update installation of 2018-03 cumulative update (KB4088787).


We ship our room systems with Windows 10 Enterprise 2016 LTSB (1607). So no feature-upgrades can produce problems, because they doesnt exist. Only updates are beeing installed.
I guess you also use the 2016 LTSB?

The problem: The SfB Room-App lost its registration for skype-mrx:// links and other sfb related links, as well as the complete settings of the Room-App (e.g. Room-Account).

As quick workaround you can edit the autostart entry to directly start the App, instead of calling the skype-mrx:// link.
After that, you can relogin with the Skype-user and the App starts. The configuration screen appears, since it has lost all settings. Do not cancel this, but configure all necessary settings.

After the settings are done, the room works and you can use it. But: the settings screen (opened with the gear icon) does not work, because it is called with another sfb-link, which is not registered anymore.

I may work on a complete fix the next days.

Current workaround:
Logon as Admin.
Check (e.g. via Taskmanager), if Skype user is logged off. If not, terminate its session.
Replace the autostart entry for the SfB Room-App at the user Skype with the following commands from an elevated cmdline:
:: Load Skype User Reg Keys
reg.exe load HKU\Skype C:\Users\Skype\NTUSER.DAT
:: delete autostart
reg.exe delete "HKU\Skype\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /v SkypeRoomSystemLaunch /f
:: add new autostart
reg.exe add "HKU\Skype\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /v "SkypeRoomSystemLaunch" /t REG_SZ /d  "cmd /q /c if exist \"%SystemDrive%\Rigel\x64\Scripts\Provisioning\launch.ps1\" (powershell -WindowStyle Hidden -ExecutionPolicy Unrestricted %SystemDrive%\Rigel\x64\Scripts\Provisioning\launch.ps1) else (explorer.exe shell:appsFolder\Microsoft.SkypeRoomSystem_8wekyb3d8bbwe!App)" /f
:: Unload Skype User Reg Keys
reg.exe unload HKU\Skype
Logoff Admin.
Logon Skype.
App should start and settings screen should be displayed.
Type in all settings and save configuration.
Note that the settings screen can not be reopened again, after saved. If you type in a wrong password. You can edit the settings via XML deployment of the settings.

Kind regards,

Thanks for the reply, we tried to defer 1709 but the defer option was already selected and 1709 downloaded, which meant we couldn't search for any other updates. We tried to update/reinstall from the store but kept getting an error.
Thank you for the detailed response. We have had to Windows Reset the Surface and are currently waiting for it to finish. This does sound like the type of issue we were having, although we are on Enterprise not LTSB.
Thanks for posting, this workaround worked for us, however now we have lost access to the settings cog in the bottom left, which we do regularly use so editing the XML is not suitable.

Has anyone heard from Microsoft on a formal resolution for this?
You sir,
are brilliant!
This works!