Skype for Business OS 10.10 Yosemite

Occasional Visitor

Seems the skype for business mac client is only compatible with 10.11, and up.. My company is on 10.10, and not sure if it's worth upgrading everyone to 10.11 just to be able to run this app. So to confirm there will be no compatibility with OS X Yosemite, correct?

2 Replies
As far as I know, there are no plans to implement support for Yosemite
El captain is required. OSX 10.11 (El Capitan) or OSX 10.12 (Sierra) Outlook Mac build 15.27 (161010) required for Outlook integration