Skype for Business issues on iOS 10 / iPhone 7

Iron Contributor

I've been having issues with my Skype for Business on iOS 10 on my iPhone 7.


I have the most recent version of SFB installed. I am unable to sign in to my SFB on my iPhone. I get various errors, some say that the server cannot be contacted, and then there is the one in the image attached: 'You're not configured to connect to the server. Please contact your support team.'


I've had SFB installed across all my devices and up until now I've never had this issue. Naturally I've made sure my DNS settings are correct. Oddly enough, despite the error and not being able to use SFB on my iPhone 7, if a contact sends me a message I get the standard iOS notification, but when I tap on that, I'm asked to sign in and I get the same error message and I go around in circles.


I have the exact same app on my iPad that has iOS 10 installed and it works perfectly. Is anyone else experiencing this?

4 Replies

I'm having the same problem. Got an iPhone 7 over the weekend, and have been unable to use the Skype client ever since. I deleted and reinstalled and all the other standard things with no luck. I've had no trouble with other clients, and it was fine on my iPhone 6s with iOS 10.

Can you please share the client logs to understand more the problem
We also have seen this behavior. Steps to resolve (at least this is what we are doing) use another account to log into the device, look for other profiles and delete them. Close the app, and terminate it is is TSR, and then reopen it. Log in with your account, and it should go through.

I had Skype for Business working fine on iPhone 6 iOS 10.3.3, when I installed it on iPad Air 2 iOS 10.3.3, I experienced the same issue you're having.  After I tried several times I decided to turn the iPad off and then back again and that did the trick.