Missing messages in new OS X client

%3CLINGO-SUB%20id%3D%22lingo-sub-26086%22%20slang%3D%22en-US%22%3EMissing%20messages%20in%20new%20OS%20X%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-26086%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI've%20just%20installed%20the%20new%20Skype%20for%20Business%20on%20my%20Mac%20book%20running%20El%20Capitan%20(10.11.6)%20and%20I've%20found%20it%20increadibly%20buggy.%20Often%20people%20cannot%20send%20me%20messages%20and%2For%20I%20will%20recieve%20each%20new%20message%20from%20the%20same%20person%20in%20new%20chat%20windows.%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20experienced%20this%3F%20It's%20so%20bad%20that%20I'm%20returning%20to%20using%20Lync%202011...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClare%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-26086%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EClient%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-39569%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20messages%20in%20new%20OS%20X%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-39569%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20the%20same%20issue%20on%20macOS%20Sierra.%20According%20to%20my%20customer%2C%20it's%20happening%20on%20Windows%2010%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20are%20a%20few%20issues%20that%20seem%20to%20be%20interrelated%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EI%20get%20a%20notification%20that%20I've%20been%26nbsp%3Bsent%20a%20message.%20The%20message%20will%26nbsp%3Bnot%20show%20up%20when%20I%20click%20the%20notification%2C%20nor%20does%20it%20show%20up%20in%20the%20message%20history%20in%20web%20Outlook.%26nbsp%3B%3C%2FLI%3E%3C%2FUL%3E%3CUL%3E%3CLI%3EI%20get%20messages%20when%20my%20customer%20goes%20idle%20that%20say%2C%20%22You%20were%20disconnected%20from%20the%20meeting%2C%22%20when%20there%20are%20clearly%20people%20still%20in%20the%20chat%20(albeit%20%22away%22).%3C%2FLI%3E%3C%2FUL%3E%3CUL%3E%3CLI%3EWhen%20the%20user%20I'm%20chatting%20with%20runs%20into%20the%20issue%20and%20sends%20me%20a%20new%20message%2C%20it%20will%20often%20show%20up%20in%20a%20new%20chat%20window%20on%20my%20end.%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20dealing%20with%20this%20for%20the%20last%20few%20days%2C%20it%20seems%20to%20manifest%20on%20my%20end%20when%20I%20leave%20a%20chat%20window%20open%20and%20the%26nbsp%3Bscreen%20saver%20activates.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20an%20O365%20customer.%20I%20am%20not%20logged%20in%20to%20any%20other%20S4B%20client%20(although%20even%20if%20I%20were%2C%20I%20should%20still%20get%20the%20message).%26nbsp%3BI%20am%26nbsp%3Bnot%20running%20Outlook%20stand-alone%20on%20this%20machine.%20Skype%20for%20Business%20is%20the%20only%20Microsoft%20app%20running.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETrying%20to%20communicate%20with%20customers%26nbsp%3Band%20having%20their%20messages%20go%20missing%20is%20unacceptable.%20This%20is%20a%20known%20issue.%20Please%20provide%20a%20fix.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-28560%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20messages%20in%20new%20OS%20X%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-28560%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Gordon.%20%26nbsp%3BDoes%20the%20person%20who%20send%20you%20the%20message%20see%20this%20error%20for%20the%20first%20message%20of%20the%20conversation%3F%20%26nbsp%3BOr%20does%20the%20sender%20see%20this%20error%20even%20you%20are%20already%20in%20the%20conversation%20wtih%20them%3F%20%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-28027%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20messages%20in%20new%20OS%20X%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-28027%22%20slang%3D%22en-US%22%3E%3CP%3EServer%20Side%20History%20requires%20Exchange%202013%20and%20newer.%20I%20am%20running%20Exchange%202010%20SP3%20so%20I%20cannot%20enable%20Server%20Side%20History.%20This%20makes%20the%20Mac%20client%20useless%20as%20every%20message%20I%20send%20to%20a%20Mac%20user%20returns%20a%20%22We%20couldn't%20send%20the%20message%22%20warning%2C%20even%20though%20the%20message%20is%20in%20fact%20received.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-26833%22%20slang%3D%22en-US%22%3ERe%3A%20Missing%20messages%20in%20new%20OS%20X%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-26833%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Clare.%20%26nbsp%3BAre%20you%20using%20SFB%20Mac%20with%20O365%2C%20Skype%20for%20Business%202015%20or%20Lync%20Server%3F%20%26nbsp%3BI%20think%20you%20are%20running%20into%20a%20known%20issue%20where%20Server%20Side%20Conversation%20History%20may%20have%20not%20enabled.%20%26nbsp%3BSFB%20Mac%20depends%20on%20Server%20Side%20Conversation%20History%20to%20correctly%20handle%20missed%20message.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi,

I've just installed the new Skype for Business on my Mac book running El Capitan (10.11.6) and I've found it increadibly buggy. Often people cannot send me messages and/or I will recieve each new message from the same person in new chat windows. 

Has anyone else experienced this? It's so bad that I'm returning to using Lync 2011...

 

Clare

4 Replies

Hi Clare.  Are you using SFB Mac with O365, Skype for Business 2015 or Lync Server?  I think you are running into a known issue where Server Side Conversation History may have not enabled.  SFB Mac depends on Server Side Conversation History to correctly handle missed message.

 

Server Side History requires Exchange 2013 and newer. I am running Exchange 2010 SP3 so I cannot enable Server Side History. This makes the Mac client useless as every message I send to a Mac user returns a "We couldn't send the message" warning, even though the message is in fact received.

Hi Gordon.  Does the person who send you the message see this error for the first message of the conversation?  Or does the sender see this error even you are already in the conversation wtih them?  

I'm having the same issue on macOS Sierra. According to my customer, it's happening on Windows 10 as well.

 

There are a few issues that seem to be interrelated: 

 

  • I get a notification that I've been sent a message. The message will not show up when I click the notification, nor does it show up in the message history in web Outlook. 
  • I get messages when my customer goes idle that say, "You were disconnected from the meeting," when there are clearly people still in the chat (albeit "away").
  • When the user I'm chatting with runs into the issue and sends me a new message, it will often show up in a new chat window on my end.

 

After dealing with this for the last few days, it seems to manifest on my end when I leave a chat window open and the screen saver activates. 

 

I am an O365 customer. I am not logged in to any other S4B client (although even if I were, I should still get the message). I am not running Outlook stand-alone on this machine. Skype for Business is the only Microsoft app running.

 

Trying to communicate with customers and having their messages go missing is unacceptable. This is a known issue. Please provide a fix.