Trouble logging into SfB w/Logitech SmartDock

%3CLINGO-SUB%20id%3D%22lingo-sub-96628%22%20slang%3D%22en-US%22%3ETrouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96628%22%20slang%3D%22en-US%22%3E%3CP%3E'We%20can't%20sign%20you%20in%20because%20the%20server%20couldn't%20be%20reached%20or%20the%20server%20version%20is%20incompatible%20with%20the%20device.'%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20gives%20me%20very%20little%20information%20to%20look%20into.%26nbsp%3B%20The%20logs%20are%20just%20as%20unhelpful.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20account%20is%20setup%20in%20Exchange%20and%20SfB%20with%20an%20appropriate%20license.%3C%2FP%3E%3CP%3EGet-CSMeetingRoom%20returns%20the%20account.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-96628%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EInstallation%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESkype%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-159979%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-159979%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issues%20on%20a%20SRSv2%20running%20version%203.0.15.0.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20SRS%20user%20is%20enabled%26nbsp%3Bin%20O365%20(SfB%20Online).%20O365%20is%20federated%20(ADFS).%20I%20am%20wondering%20if%20that%20could%20be%20an%20issue%20or%20not%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20tenant%20was%20OAuth2ClientProfileEnabled%20for%20a%20while%2C%20but%20I%20have%20tried%20to%20revert%20that%20(Set-OrganizationConfig%20-%20OAuth2ClientProfileEnabled%20%24false)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20notice%20that%20none%20of%20the%20users%20in%20this%20tenant%20are%20authenticated%20correctly%20using%26nbsp%3Btestconnectivity.microsoft.com.%20I%20receive%20the%20following%20message%3A%3C%2FP%3E%0A%3CP%3E%22%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3ECouldn't%20sign%20in.%20Error%3A%20Error%20Message%3A%20No%20common%20authentication%20method%20detected..%3C%2FEM%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3EError%20Type%3A%20AuthenticationException.%3C%2FEM%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3EError%20Code%3A%200.%3C%2FEM%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3ERealm%3A%20SIP%20Communications%20Service.%3C%2FEM%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3EResponse%20Code%3A%20401.%3C%2FEM%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23808080%22%3E%3CEM%3EResponse%20Text%3A%20Unauthorized.%3C%2FEM%3E%3C%2FFONT%3E%22%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20users%20in%20the%20Tenant%20are%20using%20Skype%20for%20Business%20client%20on%20a%20regular%20basis.%20I%20am%20not%20able%20to%20sign%20in%20to%20a%20normal%20SfB%20client%20with%20my%20SRS%20account.%26nbsp%3B%20Should%20that%20be%20possible%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20guess%20I%20have%20a%20problem%20related%20to%20authentication%20-%20either%20because%20of%20Federation%2C%20or%20because%20of%20the%20ModernAuth%20changes%20mentioned%2C%20or%20because%20I%20can't%20run%20the%20%22Set-Mailbox%20-RoomMailboxPassword%22-command%20because%20of%20the%20federation%20situation.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAny%20responses%20are%20highly%20awaited!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-121589%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-121589%22%20slang%3D%22en-US%22%3E%3CP%3EFaced%20with%20the%20same%20issue.%20Fixed%20after%20rebuild%20image%20of%20device.%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fmt790558.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fmt790558.aspx%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20352px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F22958iA6736A7F34EA2999%2Fimage-dimensions%2F352x255%3Fv%3D1.0%22%20width%3D%22352%22%20height%3D%22255%22%20alt%3D%22image.png%22%20title%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-121192%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-121192%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20the%20Office365%20Admin%20Center%2C%20go%20to%20Setup%20%7C%20Domains%20and%20make%20sure%20all%20the%20DNS%20records%20are%20correct%20for%20your%20domain.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-121173%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-121173%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20problem%20and%20I%20am%20guessing%20it%20is%20also%20DNS.%26nbsp%3B%20What%20records%20did%20you%20need%20to%20add%2Fmodify%20to%20get%20this%20working%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96909%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96909%22%20slang%3D%22en-US%22%3E%3CP%3EIt's%20DNS%20.%20.%20.%20.it's%20always%20DNS.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96834%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96834%22%20slang%3D%22en-US%22%3EOnline%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96823%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96823%22%20slang%3D%22en-US%22%3E%3CP%3ETake%20a%20look%20at%20this%20short%20step%20by%20step%20how%20to%20use%20snooper%20to%20read%20logs%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.pure-ip.com%2Fportal%2Fhelpcenter%2Farticles%2Fskype-for-business-how-to-use-snooper-to-analyse-troubleshooting-logs%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.pure-ip.com%2Fportal%2Fhelpcenter%2Farticles%2Fskype-for-business-how-to-use-snooper-to-analyse-troubleshooting-logs%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EInstall%20this%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fdownload%2Fdetails.aspx%3Fid%3D47263%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fdownload%2Fdetails.aspx%3Fid%3D47263%3C%2FA%3E%3C%2FP%3E%3CP%3EYou%20will%20find%20snooper%20in%20the%20folder%20you%20install%20these%20tools%20to.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96821%22%20slang%3D%22en-US%22%3ERE%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96821%22%20slang%3D%22en-US%22%3Ethe%20detailed%20log%20is%20under%20users%5Cskype%5CAppData...%5Clocalstate%5Ctracing%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96811%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96811%22%20slang%3D%22en-US%22%3EAre%20you%20using%20Skype%20for%20Business%20Online%2C%20or%20Server%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-973786%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20logging%20into%20SfB%20w%2FLogitech%20SmartDock%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-973786%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20reason%20I%20was%20seeing%20this%20is%20because%20we%20force%20you%20to%20enroll%20in%20MFA%20for%20SSPR%20so%20it%20doesn't%20allow%20you%20to%20fully%20login%20until%20you%20have%20that%20configured%20so%20I%20had%20to%20login%20to%20a%20browser%20on%20my%20computer%20as%20the%20user%20and%20setup%20MFA%20questions%20for%20the%20acccount.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

'We can't sign you in because the server couldn't be reached or the server version is incompatible with the device.'

 

This gives me very little information to look into.  The logs are just as unhelpful.

 

The account is setup in Exchange and SfB with an appropriate license.

Get-CSMeetingRoom returns the account.

 

10 Replies
Are you using Skype for Business Online, or Server?
the detailed log is under users\skype\AppData...\localstate\tracing

Take a look at this short step by step how to use snooper to read logs:
https://support.pure-ip.com/portal/helpcenter/articles/skype-for-business-how-to-use-snooper-to-anal...

Install this:
https://www.microsoft.com/en-us/download/details.aspx?id=47263

You will find snooper in the folder you install these tools to.

It's DNS . . . .it's always DNS.

I am having the same problem and I am guessing it is also DNS.  What records did you need to add/modify to get this working?

In the Office365 Admin Center, go to Setup | Domains and make sure all the DNS records are correct for your domain. 

Faced with the same issue. Fixed after rebuild image of device.
https://technet.microsoft.com/en-us/library/mt790558.aspx

image.png

I have the same issues on a SRSv2 running version 3.0.15.0.

 

The SRS user is enabled in O365 (SfB Online). O365 is federated (ADFS). I am wondering if that could be an issue or not?

 

The tenant was OAuth2ClientProfileEnabled for a while, but I have tried to revert that (Set-OrganizationConfig - OAuth2ClientProfileEnabled $false)

 

I notice that none of the users in this tenant are authenticated correctly using testconnectivity.microsoft.com. I receive the following message:

"Couldn't sign in. Error: Error Message: No common authentication method detected..
Error Type: AuthenticationException.
Error Code: 0.
Realm: SIP Communications Service.
Response Code: 401.
Response Text: Unauthorized."

 

The users in the Tenant are using Skype for Business client on a regular basis. I am not able to sign in to a normal SfB client with my SRS account.  Should that be possible?

 

I guess I have a problem related to authentication - either because of Federation, or because of the ModernAuth changes mentioned, or because I can't run the "Set-Mailbox -RoomMailboxPassword"-command because of the federation situation.

 

Any responses are highly awaited!

The reason I was seeing this is because we force you to enroll in MFA for SSPR so it doesn't allow you to fully login until you have that configured so I had to login to a browser on my computer as the user and setup MFA questions for the acccount.