Skype, proxy and Exchange Autodiscover

%3CLINGO-SUB%20id%3D%22lingo-sub-228900%22%20slang%3D%22en-US%22%3ESkype%2C%20proxy%20and%20Exchange%20Autodiscover%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-228900%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3EI%20have%20setup%20the%20%22netsh%20winhttp%20proxy%22%20on%20my%20Skype%20Front%20End%20servers%2C%20so%20they%20should%20be%20able%20to%20reach%20the%20Exchange's%20autodiscover%20service.%20And%2C%20that%20is%20working%20more%20than%20perfectly%20for%20the%20on-premises.%20But%20when%20I'm%20trying%20to%20perform%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3CEM%3ETest-CsExStorageConnectivity%20-SipUri%20sip%3AExcOnlineUser01%40company.com%20-verbose%3C%2FEM%3E%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EFrom%20the%20output%20I%20can%20see%20it%20is%20finding%20from%20the%20on-premises%20Exchange%20the%20user's%26nbsp%3Btarget%20address%3A%3C%2FP%3E%3CP%3EExcOnlineUser01%40company.mail.onmicrosoft.com%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELater%20on%20the%20output%20I%20can%20see%3A%3C%2FP%3E%3CP%3E%3CEM%3ETrying%20to%20get%20Autodiscover%20redirection%20URL%20from%20%3CA%20href%3D%22http%3A%2F%2Fautodiscover.company.mail.onmicrosoft.com%2Fautodiscover%2Fautodiscover.xml%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttp%3A%2F%2Fautodiscover.company.mail.onmicrosoft.com%2Fautodiscover%2Fautodiscover.xml%3C%2FA%3E.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3ERequest%20error%3A%20Unable%20to%20connect%20to%20the%20remote%20server%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3ENo%20Autodiscover%20redirection%20URL%20was%20returned.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20looking%20for%20this%20by%20the%20NetMon%2C%20I%20can%20see%20no%20tries%20to%20proxy%20at%20all.%20Instead%20the%20Skype%20server%20is%20trying%20to%20connect%20directly%20to%20that%20host%2C%20but%20of%20course%20it%20fails%20if%20it%20is%20not%20using%20the%20proxy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnybody%20knows%20the%20way%20to%20affecting%20to%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-228900%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeployment%20%26amp%3B%20Operations%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Super Contributor

Hi there,

I have setup the "netsh winhttp proxy" on my Skype Front End servers, so they should be able to reach the Exchange's autodiscover service. And, that is working more than perfectly for the on-premises. But when I'm trying to perform

Test-CsExStorageConnectivity -SipUri sip:ExcOnlineUser01@company.com -verbose

From the output I can see it is finding from the on-premises Exchange the user's target address:

ExcOnlineUser01@company.mail.onmicrosoft.com

 

Later on the output I can see:

Trying to get Autodiscover redirection URL from http://autodiscover.company.mail.onmicrosoft.com/autodiscover/autodiscover.xml.

 

Request error: Unable to connect to the remote server

 

No Autodiscover redirection URL was returned.

 

When looking for this by the NetMon, I can see no tries to proxy at all. Instead the Skype server is trying to connect directly to that host, but of course it fails if it is not using the proxy.

 

Anybody knows the way to affecting to this?

 

0 Replies