Skype for Business Exchange Integration problem

%3CLINGO-SUB%20id%3D%22lingo-sub-83940%22%20slang%3D%22en-US%22%3ESkype%20for%20Business%20Exchange%20Integration%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-83940%22%20slang%3D%22en-US%22%3E%3CP%3EHello%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAt%20our%20customer%20we%20have%20an%20Onpremise%20Skype%20for%20Business%202015%20server%20with%20Office%20365%20Exchange%20Online%20using%20the%20latest%20Office%20version%20and%20Windows%2010%20(1607%20or%201703)%3CBR%20%2F%3EUntil%20end%20of%20April%20beginning%20of%20May%20the%20Outlook%20Integration%20in%20the%20SfB%20client%20worked%20for%20all%20users%20without%20problems.%3CBR%20%2F%3EAround%20the%20time%20some%20users%20noticed%20that%20the%20SfB%20client%20no%20longer%20showed%20new%20missing%20calls%2C%20or%20conversations%20after%20that%20date.%3CBR%20%2F%3EWe%20tried%20to%20reinstall%20Office%20on%20the%20effected%20clients%20including%20deleting%20the%20Office%20registry%20keys.%20But%20the%20SfB%20client%20not%20even%20asked%20the%20user%20to%20reenter%20the%20account%3CBR%20%2F%3Efor%20the%20Exchange%20integration.%3CBR%20%2F%3EThe%20only%20solution%20we%20found%20was%20setting%20the%20registry%20key%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EHKEY_CURRENT_USER%5CSOFTWARE%5CMicrosoft%5COffice%5C16.0%5CLync%5C%3CSIP%20address%3D%22%22%3E%5COAuthUsed%20to%200%3C%2FSIP%3E%3C%2FP%3E%3CP%3EThen%20the%20SfB%20clients%20updates%20the%20call%20history%20and%20all%20the%20other%20integration%20features%20work%20but%20only%20for%20a%20short%20time.%20(between%20minutes%20and%20a%20day)%3CBR%20%2F%3EThe%20OAuthUsed%20switches%20back%20to%200%20and%20SfB%20client%20no%20longer%20updates%20the%20informations.%3C%2FP%3E%3CP%3EWhen%20the%20same%20user%20logs%20on%20another%20computer%20with%20the%20same%20Office%20version%20everything%20works%20without%20the%20key%20and%20continue%20to%20work%20so%20far%20for%20this%20user.%3C%2FP%3E%3CP%3EThis%20problem%20so%20far%20only%20effect%2050-70%25%20of%20the%20users%20all%20using%20the%20current%20Offic%20365%20version.%3C%2FP%3E%3CP%3EAny%20solution%20to%20permanently%20fix%20this%20problem%20without%20recreating%20the%20user%20profile%20or%20reinstalling%20the%20clients%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EReinhard%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-83940%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeployment%20%26amp%3B%20Operations%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDesktop%20Client%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-84758%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20for%20Business%20Exchange%20Integration%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-84758%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3Ehave%20you%20already%20tested%20with%26nbsp%3BTest-CsExchangeStorageConnectivity%20(%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fjj204740.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fjj204740.aspx%3C%2FA%3E)%2C%20during%20the%20period%20where%20users%20are%20not%20syncing%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20faced%20same%20issues%20months%20ago%20and%20after%20some%20tests%20I've%20discovered%20that%20it%20was%20a%20connectivity%20problem%20(and%20also%20not%20all%20the%20needed%20IP%20and%20FQDNs%20was%20not%20correctly%20configured%20on%20customer's%20FW).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHtH%3C%2FP%3E%3CP%3EA.C.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-84213%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20for%20Business%20Exchange%20Integration%20problem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-84213%22%20slang%3D%22en-US%22%3EWhat%20clients%2C%20Windows%20or%20Mac%3F%20There%20was%20an%20issue%20with%20the%20Mac%20client%20but%20that%20got%20fixed.%20We%20are%20SfB%202015%20on%20premise%20and%20Exchange%20Online%20and%20shows%20for%20me.%20No%20reg%20hacks.%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hello

 

At our customer we have an Onpremise Skype for Business 2015 server with Office 365 Exchange Online using the latest Office version and Windows 10 (1607 or 1703)
Until end of April beginning of May the Outlook Integration in the SfB client worked for all users without problems.
Around the time some users noticed that the SfB client no longer showed new missing calls, or conversations after that date.
We tried to reinstall Office on the effected clients including deleting the Office registry keys. But the SfB client not even asked the user to reenter the account
for the Exchange integration.
The only solution we found was setting the registry key


HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Lync\<SIP address>\OAuthUsed to 0

Then the SfB clients updates the call history and all the other integration features work but only for a short time. (between minutes and a day)
The OAuthUsed switches back to 0 and SfB client no longer updates the informations.

When the same user logs on another computer with the same Office version everything works without the key and continue to work so far for this user.

This problem so far only effect 50-70% of the users all using the current Offic 365 version.

Any solution to permanently fix this problem without recreating the user profile or reinstalling the clients?

 

Regards,

Reinhard

2 Replies
Highlighted
What clients, Windows or Mac? There was an issue with the Mac client but that got fixed. We are SfB 2015 on premise and Exchange Online and shows for me. No reg hacks.
Highlighted

Hi,

have you already tested with Test-CsExchangeStorageConnectivity (https://technet.microsoft.com/en-us/library/jj204740.aspx), during the period where users are not syncing ?

 

I've faced same issues months ago and after some tests I've discovered that it was a connectivity problem (and also not all the needed IP and FQDNs was not correctly configured on customer's FW).

 

HtH

A.C.