Skype For Business Call Queues not phoning agents

%3CLINGO-SUB%20id%3D%22lingo-sub-181077%22%20slang%3D%22en-US%22%3ESkype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-181077%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAll%20of%20a%20sudden%20call%20queues%20are%20not%20phoning%20anyone%2C%20we%20use%20Office%20365%20Groups%20for%20our%20agents%20and%20I%20can%20see%20our%20agents%20in%20PowerShell%20listed.%20We%20use%20Auto%20Attendants%20and%20I%20can%20see%20that%20the%20AA%20phones%20the%20call%20queue%20but%20the%20call%20queue%20just%20sits%20in%20hold%20music%20without%20actually%20dialling%20either%20agent%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERyan%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-181077%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECall%20Queues%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESkype%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-188409%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-188409%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20you%20added%20your%20own%20domain%20%2B%20onmicrosoft%3F%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3ECan%20you%20screenshot%20your%20settings%20on%20%26gt%3B%20Organization%20%26gt%3B%20External%20Communication%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERyan%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-186312%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-186312%22%20slang%3D%22en-US%22%3E%3CP%3EStill%20not%20working%20for%20us%2C%20currently%20working%20through%20with%20a%20support%20person%20but%20not%20having%20much%20luck%20at%20all.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-185956%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-185956%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue%20here%20didn't%20have%20that%20in%20our%20list%20of%20allowed%20and%20already%20have%201%20working%20queue%20but%20having%20setup%205%20new%20queues%20last%20week%20all%20that%20happens%20when%20you%20call%20them%20is%20you%20get%20On%20Hold%20music%2C%20just%20trying%20the%20addition%20of%20the%20onmicrosoft.com%20domain%20to%20the%20external%20comms%20and%20will%20wait%20an%20hour%20to%20see%20if%20it%20works.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-184356%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-184356%22%20slang%3D%22en-US%22%3EOn%20for%20allowed%20domains%20with%20a%20couple%20of%20domains%20in%20there%20but%20not%20ours%20our%20onMicrosoft.%3CBR%20%2F%3E%3CBR%20%2F%3ESomething%20has%20obviously%20changed%20because%20it%20didn't%20require%20it%20before%20for%20the%20call%20queues%20to%20work.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-184351%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-184351%22%20slang%3D%22en-US%22%3E%3CP%3EWait%2C%20what%20was%20it%20set%20to%20before%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-183688%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-183688%22%20slang%3D%22en-US%22%3E%3CP%3EFinally%20got%20a%20response%2C%20we%20had%20to%20add%20onmicrosoft%20to%20our%20allowed%20domains%20in%20Admin%20console%20under%26nbsp%3B%3C%2FP%3E%3CP%3EOrganization%20%26gt%3B%20External%20Communications%20%26gt%3B%20select%20%22On%20for%20allowed%20domains%22%20then%20added%20onmicrosoft%20to%20the%20domains.%26nbsp%3B%20I%20also%20added%20our%20own%20domain%20for%20good%20measure.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAfter%20I%20did%20that%20my%20call%20queues%20started%20working%2C%20odd%20behaviour%20as%20it%20wasn't%20working%20prior%20to%20this%20without%20that.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-182121%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-182121%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20David%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20i'm%20still%20waiting%20on%20my%20ticket%2C%20having%20had%20to%20chase%20also.%20Problem%20still%20occurs%20and%20we%20are%20unable%20to%20migrate%20fully%20to%20Sfb%20Online%20until%20this%20is%20resolved.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWill%20update%20here%20if%20i%20get%20a%20response%2C%20but%20as%20you%20can't%20really%20configure%20it%20wrongly%20it%20must%20be%20something%20on%20Microsoft's%20end.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERyan%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-182116%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-182116%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Ryan%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20you%20ever%20get%20a%20fix%20for%20this%3F%20I'm%20having%20exactly%20the%20same%20problem%2C%20call%20queues%20getting%20music%20on%20hold%20only%20and%20not%20transferring%20to%20any%20users%20in%20the%20distribution%20list.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDavid%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-181276%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-181276%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20a%20ticket%20open%2C%20but%20no%20resolution%20yet.%20Very%20strange%2C%20it%20was%20all%20working%20but%20we%20had%20this%20AD%20outage%20the%20other%20day%20and%20after%20that%20this%20seems%20to%20of%20started.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERyan%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-181261%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-181261%22%20slang%3D%22en-US%22%3E%3CP%3ENot%20sure%2C%20I%20might%20open%20a%20case%20with%20O365%20support%20for%20that%20one.%26nbsp%3B%20There's%20not%20much%20mis-configuration%20you%20can%20do%20to%20make%20it%20not%20work%2C%20so%20it%20might%20be%20on%20their%20end.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-181238%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-181238%22%20slang%3D%22en-US%22%3E%3CP%3EYeah%20SIP%20is%20working%2C%20and%20in%20PS%20I%20can%20see%20the%20agents%20in%20the%20group%20are%20listed.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20created%20new%20Call%20Queues%2C%20I%20created%20a%20call%20queue%20with%20a%20new%20group%20and%20nothing%20works%20it%20just%20goes%20to%20hold%20and%20then%20disconnects%20(I%20configured%20it%20on%20purpose).%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-181201%22%20slang%3D%22en-US%22%3ERe%3A%20Skype%20For%20Business%20Call%20Queues%20not%20phoning%20agents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-181201%22%20slang%3D%22en-US%22%3E%3CP%3EI%20haven't%20seen%20that%20issue%2C%20can%20you%20call%20the%20users%20directly%3F%26nbsp%3B%20What%20happens%20if%20you%20remove%20and%20add%20them%20to%20the%20queue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,


All of a sudden call queues are not phoning anyone, we use Office 365 Groups for our agents and I can see our agents in PowerShell listed. We use Auto Attendants and I can see that the AA phones the call queue but the call queue just sits in hold music without actually dialling either agent?

 

Ryan

12 Replies

I haven't seen that issue, can you call the users directly?  What happens if you remove and add them to the queue?

Yeah SIP is working, and in PS I can see the agents in the group are listed. 

I've created new Call Queues, I created a call queue with a new group and nothing works it just goes to hold and then disconnects (I configured it on purpose). 

Not sure, I might open a case with O365 support for that one.  There's not much mis-configuration you can do to make it not work, so it might be on their end.

Have a ticket open, but no resolution yet. Very strange, it was all working but we had this AD outage the other day and after that this seems to of started. 

 

Ryan

Hello Ryan,

 

Did you ever get a fix for this? I'm having exactly the same problem, call queues getting music on hold only and not transferring to any users in the distribution list.

 

Thanks

 

David

Hi David,

 

No i'm still waiting on my ticket, having had to chase also. Problem still occurs and we are unable to migrate fully to Sfb Online until this is resolved.

 

Will update here if i get a response, but as you can't really configure it wrongly it must be something on Microsoft's end.


Thanks

 

Ryan

Finally got a response, we had to add onmicrosoft to our allowed domains in Admin console under 

Organization > External Communications > select "On for allowed domains" then added onmicrosoft to the domains.  I also added our own domain for good measure. 


After I did that my call queues started working, odd behaviour as it wasn't working prior to this without that. 

Wait, what was it set to before?

On for allowed domains with a couple of domains in there but not ours our onMicrosoft.

Something has obviously changed because it didn't require it before for the call queues to work.

Same issue here didn't have that in our list of allowed and already have 1 working queue but having setup 5 new queues last week all that happens when you call them is you get On Hold music, just trying the addition of the onmicrosoft.com domain to the external comms and will wait an hour to see if it works.

Still not working for us, currently working through with a support person but not having much luck at all.

So you added your own domain + onmicrosoft? 

Can you screenshot your settings on > Organization > External Communication 

 

Ryan