CallerID not changing

New Contributor

Hi, 

 

Im struggling with changing the CallerID of the users in our tenant. 

 

I followed the steps from https://docs.microsoft.com/en-us/skypeforbusiness/what-are-calling-plans-in-office-365/set-the-calle...

 

I've assigned a CallingLineIdentity to all users, but the CallerID doesn't change. When you make a call the personal number of the user appears. The only CallingLineIdentity policy that does work on the users is the Anonymous policy. When I assign a policy with the servicenumber, it changes back to the personal number of the user. 

I've tried setting the CallingLineIdentity back to $NULL and then back to one i've created earlier but there is no result. 

 

Can someone help me out on this one? :)

 

Here is a short transcript of the commands I've used to achieve this:

To make the CallingLineIdentity:
New-CsCallingLineIdentity -Identity "IDNAME" -CallingIdSubstitute "Service" -ServiceNumber "PHONENUMBER" -EnableUserOverride $false -Verbose

To assign the CallingLineIdentity:
Grant-CsCallingLineIdentity -Identity "USERNAME@DOMAIN.COM" -PolicyName IDNAME

To check if the CallingLineIdentity is assigned:
Get-CsOnlineUser -Identity "USERNAME@DOMAIN.COM" | FL CallingLineIdentity
2 Replies

Strange... those commands just sort of work for me.  Are you 100% sure that you're using a service number and not a user number?

Yes,

 

I've even tried with another service number, but without result. 

 

The only policy it's listening to, is the anonymous policy. All the other ones aren't affecting the users.