Does SharePointDsc need PowerShell v4 support?

Published 05-27-2020 02:00 PM 1,772 Views
Microsoft

When SharePointDsc started, PowerShell v4 was heavily used. Because of the way the LCM worked in PowerShell v4 (all runs were started under the SYSTEM account), we had to implement a workaround to make sure we were able to access the databases. This meant we required CredSSP to be configured and Verbose logging to be supressed.

 

With the introduction of the PsDscRunAsCredential in PowerShell v5 all of this belonged to the past. You could not natively specify a RunAs account, which no longer required CredSSP. Another benefit was better performance and Verbose logging to function properly.

 

Over the past years, we have most environment being upgraded to PowerShell v5. Pretty much every issue created in the issue list is mentioning the use of PowerShell v5. The WMF5.1 framework (which contains PowerShell v5) is available for all currently supported operating systems, so all environment are theoretically able to run PowerShell v5.

 

That is why we are considering dropping the support for PowerShell v4. But to make sure we aren't overlooking anything, we are interested in what you think! Are you still using PowerShell v4? Is there a specific reason you are not upgrading to PowerShell v5? Do you see any reason for not dropping v4 support? Is there anything we might not have thought of?

 

Please join the discussion in the following issue in our issue list:

https://github.com/dsccommunity/SharePointDsc/issues/1207

%3CLINGO-SUB%20id%3D%22lingo-sub-1421917%22%20slang%3D%22en-US%22%3EDoes%20SharePointDsc%20need%20PowerShell%20v4%20support%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1421917%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20SharePointDsc%20started%2C%20PowerShell%20v4%20was%20heavily%20used.%20Because%20of%20the%20way%20the%20LCM%20worked%20in%20PowerShell%20v4%20(all%20runs%20were%20started%20under%20the%20SYSTEM%20account)%2C%20we%20had%20to%20implement%20a%20workaround%20to%20make%20sure%20we%20were%20able%20to%20access%20the%20databases.%20This%20meant%20we%20required%20CredSSP%20to%20be%20configured%20and%20Verbose%20logging%20to%20be%20supressed.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWith%20the%20introduction%20of%20the%20PsDscRunAsCredential%20in%20PowerShell%20v5%20all%20of%20this%20belonged%20to%20the%20past.%20You%20could%20not%20natively%20specify%20a%20RunAs%20account%2C%20which%20no%20longer%20required%20CredSSP.%20Another%20benefit%20was%20better%20performance%20and%20Verbose%20logging%20to%20function%20properly.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EOver%20the%20past%20years%2C%20we%20have%20most%20environment%20being%20upgraded%20to%20PowerShell%20v5.%20Pretty%20much%20every%20issue%20created%20in%20the%20issue%20list%20is%20mentioning%20the%20use%20of%20PowerShell%20v5.%20The%20WMF5.1%20framework%20(which%20contains%20PowerShell%20v5)%20is%20available%20for%20all%20currently%20supported%20operating%20systems%2C%20so%20all%20environment%20are%20theoretically%20able%20to%20run%20PowerShell%20v5.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThat%20is%20why%20we%20are%20considering%20dropping%20the%20support%20for%20PowerShell%20v4.%20But%20to%20make%20sure%20we%20aren't%20overlooking%20anything%2C%20we%20are%20interested%20in%20what%20you%20think!%20Are%20you%20still%20using%20PowerShell%20v4%3F%20Is%20there%20a%20specific%20reason%20you%20are%20not%20upgrading%20to%20PowerShell%20v5%3F%20Do%20you%20see%20any%20reason%20for%20not%20dropping%20v4%20support%3F%20Is%20there%20anything%20we%20might%20not%20have%20thought%20of%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPlease%20join%20the%20discussion%20in%20the%20following%20issue%20in%20our%20issue%20list%3A%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2Fdsccommunity%2FSharePointDsc%2Fissues%2F1207%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2Fdsccommunity%2FSharePointDsc%2Fissues%2F1207%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-TEASER%20id%3D%22lingo-teaser-1421917%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20need%20your%20input%3F%20For%20the%20next%20major%20release%2C%20we%20are%20considering%20dropping%20support%20for%20PowerShell%20v4%20and%20would%20like%20to%20know%20what%20you%20think!%3C%2FP%3E%3C%2FLINGO-TEASER%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1421917%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAnnouncement%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Esharepoint%202013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%202016%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%202019%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Version history
Last update:
‎May 27 2020 02:00 PM
Updated by: