Workflow Error in SharePoint Online

Copper Contributor

I have been trying to get a clear answer on what has changed in SharePoint Online recently, when being used with SharePoint Designer, but have not gotten any clear answers.  When SharePoint Online was rolled out, and up until as recently as my last job, using SPD was the only way to truly be able to create workflows that actually make a company operate (I'm sorry the canned ones are relatively useless outside of a few scenarios).  SPD was the one way to actually make SharePoint useful in automating business practices.


With the workflows I am creating now, I have run into an issue I am HOPING someone in the community can assist with because I've ultimately been given the runaround by the support team (I'm sorry, but this is how I truly feel because when I've worked with support in the past, they have worked on making things right).  I am simply trying to create a 2013 workflow that users can simply initialize.  No matter what the workflow is set to do, it simply does not work.  I was pointed to a solution for 2010 workflows, where they are exported to Visio and reimported, and this made the 2010 workflows work properly.  The 2013 ones, however, still throw errors like:


RequestorId: 059865bc-a7b3-12c8-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 403 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"X-MSDAVEXT_Error":["917656; Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+select+the+option+to+login+automatically."],"X-SP-SERVERSTATE":["ReadOnly=0"],"DATASERVICEVERSION":["3.0"],"SPClientServiceRequestDuration":["101"],"SPRequestDuration":["271"],"SPRequestGuid":["059865bc-a7b3-12c8-a694-43e1cc709f26"],"request-id":["059865bc-a7b3-12c8-a694-43e1cc709f26"],"Strict-Transport-Security":["max-age=31536000"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":[""],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Thu, 07 Sep 2017 09:42:50 GMT"],"P3P":["CP=\"ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI\""],"Server":["Microsoft-IIS\/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at System.Activities.Statements.Throw.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation) Exception from activity Throw If Sequence Sequence TryCatch Sequence Microsoft.SharePoint.WorkflowServices.Activities.RetryForDurationPolicy HTTPPost_WorkflowInterop_EnableEvents WorkflowInterop DynamicActivity<Guid> Stage 1 Sequence Flowchart Sequence Supply Request WF.WorkflowXaml_d32b0e01_66f3_4239_8264_0774baaafee9


I have never had to do any strange work along with simply publishing the workflow for it to work.  Support states that the settings on the tenant are configured properly.


I hope someone has some insight because I feel like this product has gotten to the point it's borderline unusable because of many of the changes that have been made.

8 Replies
Well, we've never had an issue with SPD not working like its supposed to in almost 4 years of being on SPO. So I don't think it is the platform.

Your issue clearly lies right here: Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+select+the+option+to+login+automatically

Potentially some kind of sign-in related error? Maybe ADFS or something similar. That's where to start.

Would that be a problem if we were just using AD connect, and not a full ADFS solution?  I don't get why would it would be throwing access denied responses when all of my users are directly logged into the SPO portal.

Out of curiosity: what is your workflow actually doing? Are those issues happening with all the workflows in your tenant?

If it's a 2013 workflow, it legitimately doesn't do anything.  It will basically go to the first stage and freeze before it ever executes anything within the stage itself.  I've simply tried to have it input a value of 1 into a field, and it can't even accomplish that.

Check to see if you are using a username within the workflow, if so change it to an email address and see if that resolves the issue. 

That's the thing... If it's a 2010 workflow, it'll run just fine.  It's only if it's a 2013 workflow, and it doesn't matter what the instruction is.  There aren't usernames, emails, etc, being utilized in the 2013 workflow.  I can literally tell it to simply change a value from blank to a 1 and it will never pass that step.  This isn't an app step or anything like that, just a simple Set field to value command, and that won't even work for anyone but the Company Administrator.

I just received this error as well.  I think it might have to do with an App Step.  I don't know what would be required to resolve it.