Word custom Document Property doesn't work after saving document in SP library

Copper Contributor

I have created a Word document and have created some custom Document Properties. It all works very well. I have the fields placed within my document and when I alter them I see the value change reflected in the Info pane, eg:

2022-05-19 12_06_01-Employment Contract 2022 - Copy - Copy.docx - Word.png

in the document, and in the File > Info pane, Show All Properties:

2022-05-19 12_08_28-.png

When I make a change in the document, the change is reflected here. 


However, once I have uploaded the document into a SharePoint library and then download the document from the library and edit the custom field in the document it is no longer updated in the File > Info pane. The info in there is just static, the value it was when saved in the library, there is no longer a live link between the field in the document and the File Info. The field is still in the body of the document and I can edit it, it's just that the changes don't make it out to the File Info. This is a real problem because my library needs to read the value from the document as I am running Power Automate flows using this info. 


To reproduce the problem, 

  1. Create a new Word doc
  2. Create a custom Document Property
  3. Insert the custom Document Property field into the body of the document.
  4. Check that changes in the field in the body of the document are reflected in the File > Info > Document properties and vice versa, changes there are reflected in the body of the document.
  5. Save the document 
  6. Upload it to a SharePoint library (not Shared Folders) but a document library.
  7. Download the document from the library, edit your custom field in the body.
  8. Check in the File > Info > Document Properties and the value has not changed, it is the same value as when the document was saved in the list.

It appears this only happens for custom Document Properties. I tried placing a field for the Company Document Property in the body and the live link seems to survive being saved to the list.


Has anyone noticed this behaviour and especially, does anyone have a way to work-around it?


5 Replies
Am I the only person to experience this?

@KarlInOz1 Are you downloading the document locally on your system OR you are opening online document using browser/office app?

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

I'm getting this now too. It is a big pain and it has affected contract documents where we use fields in our templates to ensure consistency.



Go to File | Options | Trust Center and click Trust Center Settings... Select the Privacy Options tab and make sure that the box for "Remove personal information from file properties on save" is not checked.

Let me know if that worked for you.

I may have found the why and possibly how to fix.

My issue specifically was the Document Property Quick Part was loading partial values from a SharePoint List in the document, however the SharePoint Properties window showed all options.

I went into the Developer menu and looked at my Quick Parts that were having the issue - the list of options was either missing or only had a portion of the items. Weird.

So, I went into the template used for the content type - and behold, the Quick Parts within the template were missing choices just as my document was. The difference here is that the SharePoint Properties window is taking quite a long time to load. As I write this comment it is still showing "Loading" - I suspect that my list has a lot of data, and it may have only partially loaded when I had created the template file. 

So, to bring the point back around, I suspect that Lookup fields with many options (or all Lookup fields) do not have a "live" link but only update in the content type template upon creation.