SOLVED

Weird problems saving to a list

Occasional Contributor

We have a weird problem where when users save updates to a list their screen takes 45-60 seconds to refresh after they hit the save button.  The weird thing is that the data is saved almost immediately, (other users can see the data immediately), but their screen won't show that for up to 60 seconds.

 

The funny thing is that this all started yesterday morning.  The night before we had tried to change the IP addresses on all of our servers in one location, and in the process of failing over to our hot site something 'hiccupped' and the entire farm was fubar'd for about 3 hours.  When it was all back up it looked like everything was working fine, until these users started complaining.  We haven't see any other problems like this (yet), and we've tested a bunch of lists/libraries looking for similar problems.

 

It appears to be confined to the list itself.  We've made templates from the list and the problem seems to follow the list template, but ONLY if we create that list on the exact same sub-site.  If we use that list template on a different site in the same SC it appears to work fine, but if we create a list using that template on the original site then it gives us the same problem.  That has got us completely stumped.

 

Any suggestions would be VERY much appreciated.

Ted

 

2 Replies
Oh, and I forgot to say that I just went through and rebooted every server in the farm in both sites.
The DBA's say the sql boxes are fine. The Networking team says all the IP issues are fixed, and the load balancers are fine. And lastly the server team says the servers themselves all look fine.

Of course.
best response confirmed by Ted1234 (Occasional Contributor)
Solution
I'll reply to my own question in case anyone else has a similar problem.

The issue was that at some point in the past there had been a 2013 workflow that was added to this list. That put an event reciever on the list that was still there, even though the workflow was gone.

On the workflow manager server we ran the GetWFFarmStatus and Get-SBFarmStatus commands, and that showed us that the services were not running.

The fun part about this was that if you just looked in the Services list it showed them as running. But if you clicked on them the only option was to Start them, even though the status showed them as running. Once we clicked start on them everything worked properly.