Weird metadata column issue in Document Library

Highlighted
Contributor

Hi all - 

 

A weird issue cropped up last week in one of our SharePoint online document libraries. We have a metadata column that we use for consistent tagging across multiple subsites. It is a site column set at the site collection top level called XX File Tag. It points to a term set at the site collection level called "File Tags" that has a default tag set of "I do not know" - last week, while trying to update these values we couldn't. Literally. It's like this I do not know tag has taken over the library. I even tried renaming the tag to "TBD" and removing it as a default. I can tag a file now with TBD but it shows in the column as "I do not know" - has ANYONE seen this? One thing I was able to narrow this down to is it is only happening when the file has been uploaded by an external user and then an internal user tries to modify the tag.

 

When a term is edited/re-labeled, shouldn't that term change be seen anywhere the set it used? Also - has anyone run into the issue where they cannot edit a metadata column field for a file uploaded by an external user with contribute access? (I have full owner access as does a colleague who tried). It's like this "I do not know" tag has set up house in the library and is refusing to leave. Very weird.

 

Quick Update: I re-indexed the library and now am seeing "TBD" rather than "I do not know" - but still cannot edit the column when the file was previously uploaded by an external user.

 

UPDATE: I have been able to narrow this down - a bit - this only happens with non-Office365 native documents (.rvt, .dwg) and "certain" external users. CRAZY MAKING - as there is no way to even recreate by myself.

0 Replies