Very odd & intermittent error opening a particular library

Steel Contributor

A user has reported that sometimes (very randomly/intermittently) when they open a particular document library on their site, they are greeted with this message:

Sharepoint error message.png

I've done a bit of research and as near as I can tell "ko.computed" refers to some component of knockout.js. However, I have absolutely no clue what would cause this error to appear when opening up a normal, garden variety Document Library. Furthermore, it seems to be happening to just one person. There are about 20 users with access to the site/library, and the only one having this issue is the person who created the site. I suppose it could be a browser or cache issue, but it's so random that it's hard to know if using another browser "fixes" it or not.

11 Replies



I have never seen this before. No lookups on the library to other lists etc? 


Report it as a ticket in the Office 365 Admin centre as this looks like a code issue.

@Andrew Hodges , nope, no other columns in the library (aside from the library standard ones). The problem with reporting it is that it's terribly intermittent and we haven't found a way to reliably replicate it. In fact, it's ONLY happening (at this point) to ONE user in the group/site. As someone who's been on the receiving end of those support calls, I know that if they can't replicate it, they can't diagnose it and if they can't diagnose it, they can't fix it.

@Chad_V_Kealey We have a client with the same issue. But it is happening to most everyone. They use Macs, not sure what your users are using. They use Chrome and I have had them try Safari, clear the history and cache on Chrome. I even re-created the views to try and get this resolved. Nothing has seemed to help. I can't replicate it on my windows 10 PC.



Soo it's been a while since you've posted this originally, but I see it's still an issue as I'm currently experiencing the error. I'm also the creator of the site that I'm now experiencing the error in... As a daily & experienced user of SharePoint I can say I have never encountered this wonder, but now I have...

I will say I encountered this wile re-organizing folders etc. so I was in the midst of already having moved multiple documents & I'm in Chrome while on a Windows 10 os. After clearing my cache I was able to move the files I was originally attempting. So I'm not sure if that helps anyone troubleshoot, but just thought I'd drop a note to say this is still an issue one can experience :)


Have an Awesome Day!

@Hi_Im_Jade OK, I've been having this same issue for a few weeks now. How do I clear the cache?



This refers to the browser cache. You can trial opening the site in private/incognito mode to check if it works, if it works then clearing the cache should correct this.
Hey @ggeremia! You can do the suggestion that BarryAnderson has left or to clear your cache in the easiest manner; you press the Function key [Fn] & [F5] on your keyboard at the same time & that should clear your cache. If you're not able to do that, then here are alternative steps for Chrome, if you use another browser they should be the same or similar steps;

1. On your computer, open Chrome.
2. At the top right, click More .
3. Click More tools. Clear browsing data.
4. At the top, choose a time range. To delete everything, select All time.
5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
6. Click Clear data.

@Chad_V_Kealey I have users also reporting this error when trying to move files between folders. I have advised them to clear the cache and refresh which resolved the issue temporarily. I am going to raise via Office 365 admin support as the issue does keep coming back. 

Great, thanks @BarryAnderson. I thought it meant Sharepoint cache not browser cache.

I did that and it worked temporarily before but every few months it comes up again.



I cleared my cache in chrome and it worked, so hopefully it stays working.