Users cannot create views anymore

Copper Contributor

Hi all,


we have a large list with around 26.000 elements.

Some days ago, members of the default members group of the site cannot create new views anymore.

The menu item "Create new view" is missing.

Site collection admins are still able to create new views.


Is this part of a undocumented throttling limit?


Anybody run into the same issue?


Thx, Ronny

8 Replies


I just ran into a similar issue:

For me the menu item was available and I tried to create a view. There was no error while, seemingly, creating it, but the view doesn't show up anywhere afterwards.


I ran into this issue after users reported that data from a PowerApp was not visible in a List.


Since that issue is purely related to the New Experience and all items show up in the Classic Experience, I suspect an update that must have taken place between 2023-09-20 and today, and that also broke the the Views.

Okay, looking further into it, deleting the cache wasn't enough.
I actually had to delete the Sharepoint cookies for the New Experience to show up the missing items.
This also resolved the issue of not being able to add new Views.
Okay, deleting cookies helps only for a single page load.
After a reload I am back in the same situation where new items that were created via the PowerApp are not shown.
Thanks Markus for your investigations.
Anybodey else?
Have a similar problem, list with 7000 items. The default view that only loads the items from last month (which has definitely less than 5000 items) only show items until Sept 23.
When opening in Incognito, the list loads fine and completely. But indead after reload, the items that where added after Sept 23rd are not shown anymore.
Also unable to add a new view here: I can create it but it always reverts to the default view. Very strange behaviour and unacceptable that the users cannot see the newly added records anymore. Anyona any help or solution to this?

I found only two workarounds:
- switch to the old classic view and live with the limitations that this will bring with it
- try the same account on a different computer or with a different Windows profile
Since the same account is working for me on a different computer, I assume it's - again - some hidden Microsoft / Windows / Edge setting that barely anyone knows about.
This intransparent bs is driving me crazy and wasting so much of my time.

I think Microsoft solved this issue, because all of a sudden I can see my newer items and I can create new views again. Must have been a bug.
Not on our Tenant, still some users cannot create private views. Any other idea?