User In Owner Role - No Search Results

Silver Contributor

While investigating a search problem (in Group enabled Team Sites) with MS Support, I discovered that if an account in an Office Group is assigned to the Owner Role, but not to the Member Role it will not get any search results. The user can create and edit documents, and navigate to them , but search does not find the files. I am being told that this is 'by-design' and the MS Support engineer is trying to find some documentation. This is occurring in Private group enabled sites, but not in Public group enabled sites.


This makes absolutely no sense to me and I consider this to be a major bug. If I can see the file and change the file, I should be able to search for the file. I should not have to assign a user to the Member role if they are in the Owner Role in the group.


Has anyone else experienced this behavior?

13 Replies
Well considering when your an owner you get added as a site collection admin to a site it should be irrelevant. Are you adding to the SharePoint owner group then accessing the site? I know it takes awhile for the owner to get added on as a site collection admin but that does seem kind of odd?

As a follow up, I have found a bug that prevents search results from being returned as expected in Group enabled Team site searches 

  1. If the Office Group is Public and the user is only in the Group Owner role, then searching works as expected.
  2. If the Office Group is Private, then searching does Not work as expected. A user that is only in the Group Owner role does not get any search results - adding the user to the Group Member role causes the search results to be returned, but this should not be necessary.
This bug does not affect users that are in Group Member role. 
I am working with MS Support to get this fixed.
@Geir-Magnus Pettersen@ can you offer any information about this?
I will try to reproduce this issue to see what migth be the problem.

I just tried creating a new private teamsite from sharepoint home/portal. Added an extra user as owner in the creation process. But searching with the extra user added as additional owner worked in the private modern team site.


Am I doing this wrong, could you provide some additional steps on how you added the extra user only as owner of the group?

This problem occurs when I add a user to the Owners role of the Office group in either, the O365 Admin Center Group page or in Azure AD Group management page. By using these tools, the account does not get assigned automatically to the Member Role also.

I am seeing the same behavior as you describe. The question is if this behavior is by design because of some unknown reason for private groups. Did you have a support case going for this? If not I can dig up with provisioning teams on if there is a good reason for this behavior.


Queries to search does not complain about errors as far as I can see, but there are not returned any results for the private group owner.

Yes, i do have a support ticket open. The engineer is insisting that it is by design, but when SP shows a user has full control, they should be getting search results, SP has worked like this for 15 years. The Privacy setting should only affect external system access and should not have any affect on searching when conducted within the site.


I can also confirm this behavior. I discovered this issue when creating a hub site. The News Web Part on the Hub site home page was not delivering results from all associated sites as expected. Please see my discussion on this issue:


After re-adding the user to the site, the search result is appearing as expected. 


And I agree with Dean. If the user has been granted Owner role on the site, search results should be delivered accordingly. 

If the users added to the new Group site through other tools than within SharePoint itself results in this behavior, then for me this sounds like a bug, and not by design.


@Frank-Ove Kristiansen @Dean_Gross 

I came across this issue in the past week too, and logged a support ticket only to be told it was by design. I don't see the logic why it would be designed like this, and the support team were unable to offer any additional info regarding this, except to get it into uservoice.


So now it looks like we will have to add any new owners into both the Office 365 Group, as well as the Site Owners group in SharePoint!


Do you know if a User Voice request has already been raised for it?



Hi Pete,
I haven't seen any User Voice request on this yet. There are a lot of requests. It it exists, it might be in the list in here:

@Dean_Gross any update on this issue. I have this same issue - MSFT is sending me in rounds :) any workaround that we can do to fix this? 

Sorry, no idea
Thanks for posting this. I ran across the same issue today. Was scratching my head why an owner could not search but a member with read only rights could search and get results.

Big thumbs up.!!