User can't create site - stuck on loading templates

Copper Contributor

During the process of creating a new SharePoint Online Site, after choosing the type of site, the process hangs on loading templates and the buttons can't be clicked with mouse (can use Esc key). This is happening using a normal user (note that the policy in our organization allows the creating of site by users). I've done a test using updated Edge in private mode on a windows pc as well from an android device, both unsuccessful!

The creation process does not get stuck on loading templates if an administrator account is used (tested with global admin)!

9 Replies
I'm having the same exact problem.
Hi there,

Did you ever find a resolution to this? We have two users experiencing the same issue for the last week.

Sadly I did not! I created the site with an admin account and gave ownership to the end user!

@Veselin_Markov I'm having the same issue, tried multiple computers and browsers.

@calbertin1985 @Veselin_Markov @SNezhad @haymond_st 

 

Seems like issue at Microsoft's end. Try raising a support ticket with Microsoft directly and report this behavior.

 

Follow: Get M365 Support - Online Support 


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

@Veselin_Markov 

 

I was able to create the SharePoint page through Teams as a work-around.  The page works normal as a SharePoint page should.  Not sure why it wouldn't create the page from SharePoint proper.

 

I hope this works for you.

Have exactly the same issue logged with Microsoft
I've got a ticket opened with MS about this too, but I found a workaround while working with our impacted users.

I noticed both of our impacted users had SharePoint Administrator roles assigned to their accounts, so I had them navigate to the SharePoint Admin Center site, then go to "Active Sites", and then click on "Create" on that webpage. This worked for them flawlessly.
Thanks for the advice, we don't allow our users that level of access, but if use my admin account I know I can create sites through the the Admin Portal, but don't really users doing that.
thanks again