SOLVED

Uploading user profile pictures as admin

%3CLINGO-SUB%20id%3D%22lingo-sub-15158%22%20slang%3D%22en-US%22%3EUploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15158%22%20slang%3D%22en-US%22%3E%3CP%3EDoes%20anyone%20know%20why%20I%20can%20upload%20user%20profile%20pictures%20through%20the%20SharePoint%20admin%20interface%20for%20some%20users%20but%20for%20others%20it%20says%20only%20the%20user%20can%20do%20it%2C%20there%20seems%20to%20be%20no%20pattern%20as%20to%20why%20one%20and%20not%20the%20other%3F%20Is%20there%20anyway%20round%20it%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-15158%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-144092%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-144092%22%20slang%3D%22en-US%22%3E%3CP%3EDo%20you%20let%20it%20%22bake%22%20(waiting%20an%20hour%20or%20more)%20between%20operations%3F%20Sometimes%20changes%20don't%20take%20affect%20right%20away.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-143988%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-143988%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20don't%20seem%20to%20be%20able%20to%20update%20a%20photo%20to%20a%20user%20profile%20as%20an%20admin.%26nbsp%3B%20I%20have%20set%20the%20placeholder%20synchronization%20status%20to%20'0'%20on%20a%20specific%20user%2C%20saved%20it%20and%20gone%20back%20into%20the%20profile.%26nbsp%3B%20I%20can%20remove%20it%20and%20add%20a%20photo%20and%20save%20it%20but%20everytime%20I%20go%20back%20in%2C%20the%20photo%20have%20reverted%20back%20to%20the%20old%20one%3F%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20I%20go%20and%20check%20the%20Sharepoint%20site%20where%20I%20have%20added%20%22People%22%20into%20a%20webpart%2C%20the%20users%20name%20then%20doesnt%20even%20appear%20in%20the%20AD%20dropdown%20box.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhat%20am%20I%20missing%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15448%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15448%22%20slang%3D%22en-US%22%3E%3CP%3EWe%E2%80%99ve%20experience%20the%20same%20problem%3A%20Some%20of%20the%20User%20pictures%20can%20change%20from%20admin%20and%20other%20not.%3C%2FP%3E%3CP%3EAfter%20some%20research%20I%20found%20a%20solution%20for%20this%20problem%3A%3C%2FP%3E%3CP%3EWhen%20a%20user%20change%20the%20picture%20himself%20or%20the%20picture%20is%20sync%20from%20local%20AD%20it%20can%E2%80%99t%20be%20change%20by%20admin.%3C%2FP%3E%3CP%3EIn%20the%20SharePoint%20Admin%20center%20in%20the%20user%20profile%20you%20found%20an%20option%3A%20%E2%80%9CImage%20placeholder%20synchronization%20status%E2%80%9D%20(translated%20from%20German%20Admin%20Interface)%3C%2FP%3E%3CP%3EChange%20this%20option%20to%20%E2%80%980%E2%80%99%20%E2%80%93%20save%20the%20profile%20and%20open%20it%20again%20%E2%80%93%20now%20you%20can%20change%20the%20Profile%20Picture%26nbsp%3B%3Cimg%20id%3D%22smileyhappy%22%20class%3D%22emoticon%20emoticon-smileyhappy%22%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fi%2Fsmilies%2F16x16_smiley-happy.png%22%20alt%3D%22Smiley%20Happy%22%20title%3D%22Smiley%20Happy%22%20%2F%3E%3C%2FP%3E%3CP%3EYou%20can%20do%20this%20also%20with%20Powershell%20or%20with%20other%20tools.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15229%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15229%22%20slang%3D%22en-US%22%3EThe%20profile%20picture%20actually%20goes%20into%20the%20users%20MySite%20so%20it's%20possible%20you%20don't%20have%20permissions%20in%20their%20site%20as%20the%20account%20you%20are%20using.%20Check%20if%20you%20are%20site%20collection%20administrator%20for%20MySite%20site%20collection%20which%20should%20give%20you%20enough%20permissions.%20SharePoint%20Administrator%20should%20be%20fine%20as%20well%20as%20this%20account%20works%20when%20using%20powershell%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15170%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15170%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%2C%20I'll%20try%20that%20next!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15167%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15167%22%20slang%3D%22en-US%22%3EUser%20profiles%20pictures%20is%20one%20of%20the%20biggest%20headaches%20in%20SPO...have%20you%20tried%20to%20set%20the%20photo%20using%20PowerShell%3F%20Some%20useful%20links%20for%20you%3A%3CBR%20%2F%3E-%20%3CA%20href%3D%22http%3A%2F%2Fwww.jijitechnologies.com%2Fblogs%2Fupdate-office365-user-photo-in-bulk%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Fwww.jijitechnologies.com%2Fblogs%2Fupdate-office365-user-photo-in-bulk%3C%2FA%3E%3CBR%20%2F%3E-%20%3CA%20href%3D%22https%3A%2F%2Fspbreed.wordpress.com%2F2015%2F11%2F06%2Fdemystifying-user-profile-picture-sync-in-office365%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fspbreed.wordpress.com%2F2015%2F11%2F06%2Fdemystifying-user-profile-picture-sync-in-office365%2F%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15164%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15164%22%20slang%3D%22en-US%22%3E%3CP%3EWe've%20been%20encouraging%20users%20to%20upload%20their%20own%20pictures%20but%20where%20they%20haven't%20and%20we%20have%20a%20photo%20to%20speed%20up%20the%20process%20I've%20been%20adding%20the%20photo%20manually%20for%20them%20through%20manage%20user%20profiles%20in%20the%20SharePoint%20Admin%20Centre%2C%20which%20works%20some%20of%20the%20time%20but%20on%20others%20it%20says%20'Only%26nbsp%3B%20%3CUSER%20name%3D%22%22%3E%20can%20change%20this%20photo'.%26nbsp%3B%26nbsp%3BGenerally%20there%26nbsp%3Bis%20no%20photo%20already%20uploaded%20in%20O365%20or%20Yammer%20but%20we%20have%20a%20few%20where%20they%20have%20a%20photo%20showing%26nbsp%3Bin%20Yammer%20or%20Skype%20but%20nothing%20has%20synced%20to%20Delve%20or%20SharePoint.%3C%2FUSER%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-15162%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-15162%22%20slang%3D%22en-US%22%3EIt%20should%20be%20the%20same%20for%20every%20SPO%20user...how%20are%20you%20trying%20to%20upload%20the%20picture%3A%20user%20by%20user%20following%20a%20manual%20approach%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-714627%22%20slang%3D%22en-US%22%3ERe%3A%20Uploading%20user%20profile%20pictures%20as%20admin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-714627%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F8310%22%20target%3D%22_blank%22%3E%40Heiko%20Watz%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20was%20the%20perfect%20answer.%26nbsp%3B%20I%20changed%20it%20to%200%20and%20voila%20-%20I%20could%20update%20the%20photo.%26nbsp%3B%20Thank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Does anyone know why I can upload user profile pictures through the SharePoint admin interface for some users but for others it says only the user can do it, there seems to be no pattern as to why one and not the other? Is there anyway round it?

9 Replies
Highlighted
It should be the same for every SPO user...how are you trying to upload the picture: user by user following a manual approach?

We've been encouraging users to upload their own pictures but where they haven't and we have a photo to speed up the process I've been adding the photo manually for them through manage user profiles in the SharePoint Admin Centre, which works some of the time but on others it says 'Only  <user name> can change this photo'.  Generally there is no photo already uploaded in O365 or Yammer but we have a few where they have a photo showing in Yammer or Skype but nothing has synced to Delve or SharePoint.

Highlighted
User profiles pictures is one of the biggest headaches in SPO...have you tried to set the photo using PowerShell? Some useful links for you:
- http://www.jijitechnologies.com/blogs/update-office365-user-photo-in-bulk
- https://spbreed.wordpress.com/2015/11/06/demystifying-user-profile-picture-sync-in-office365/
Highlighted

Thanks, I'll try that next!

Highlighted
The profile picture actually goes into the users MySite so it's possible you don't have permissions in their site as the account you are using. Check if you are site collection administrator for MySite site collection which should give you enough permissions. SharePoint Administrator should be fine as well as this account works when using powershell
Highlighted
Best Response confirmed by Gillian Pengelly (Occasional Contributor)
Solution

We’ve experience the same problem: Some of the User pictures can change from admin and other not.

After some research I found a solution for this problem:

When a user change the picture himself or the picture is sync from local AD it can’t be change by admin.

In the SharePoint Admin center in the user profile you found an option: “Image placeholder synchronization status” (translated from German Admin Interface)

Change this option to ‘0’ – save the profile and open it again – now you can change the Profile Picture Smiley Happy

You can do this also with Powershell or with other tools.

Highlighted

Hi, I don't seem to be able to update a photo to a user profile as an admin.  I have set the placeholder synchronization status to '0' on a specific user, saved it and gone back into the profile.  I can remove it and add a photo and save it but everytime I go back in, the photo have reverted back to the old one? 

If I go and check the Sharepoint site where I have added "People" into a webpart, the users name then doesnt even appear in the AD dropdown box.

 

What am I missing?

Highlighted

Do you let it "bake" (waiting an hour or more) between operations? Sometimes changes don't take affect right away.

Highlighted

@Heiko Watz 

This was the perfect answer.  I changed it to 0 and voila - I could update the photo.  Thank you!