Twitter Web Part not working


The Twitter web part for SharePoint online hasn't worked for a few weeks now - it's just empty!


Anyone else getting this?

5 Replies
I've been seeing the same thing. Was hoping it was my browser for blocking third party scripts, but can't even load in incognito mode.

I wonder if the twitter web part has been abandoned because I can't find anyone anywhere else complaining about it.

@Michael Butterfield I went over to firefox, turned off all block trackers features in any extensions and the browser itself and found that the twitter feed does work. 


So I can confirm it is working but if you have any features turned on to block trackers, it could prevent you from seeing the twitter feed. You may need to add exceptions for your SharePoint site to allow twitter trackers to run on when navigating that site.

@Michael Butterfield & @dmowry 


I have tried using twitter web part in my SharePoint site and it working perfectly fine for me. 


Maybe there some issue with your tenant or twitter account settings. Try using twitter web part on other sites or removing and again adding the web part to check if it works or not.


Below is the documentation of twitter web part if it helps: Use the Twitter web part 

Please click Mark as Best Response if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.


Brand new site rollout over this Xmas/New Years period and this Twitter web part is also not working for me either. It's consistently blank no matter if I try an @ handle for an account or even use a whole https:// address to a Twitter account. Tried Edge, Chrome and Incognito in both. Tried turning off Ghostery on both - the only Ad blocking extension isntalled.

@Michael Butterfield 

Hi - am having the same problem - did you ever find a fix?