There was a problem validating data

Occasional Contributor

In sharepoint default form, an error message appears  on save when you add sharepoint group name in the person or group column type. The column type is configured to accept person or groups.

I do not have any validation setting or any column validation formula place in any of the column. Am not sure why this error suddenly pops up for no reason.

 

Please suggest how to resolve the below issue.

 

ShibuMathew_0-1641973585322.png

 

 

 

9 Replies

@Shibu Mathew I just ran into a similar issue and was able to get around it by changing the "Show Field" to just "Name", rather than "Name (With Presence)", after that I was able to add groups to the column

 

Tim_Roe_0-1643313168405.png

 

I have tired that option but still it was not working. Finally after all my try, I have to delete the list and recreate it. The other solution is if you convert the sharepoint default form to custom powerapps the validation error does not occur on the person or group column.

@Shibu Mathew I'm suddenly having this problem as well.   It seems to only happen for recently created users.   It's been well past a week and I still have the error.  Editing the column to not include presence did not resolve the issue for me.  Any luck with another fix?  Thanks!

Actually , I found a workaround! It works when I use Chrome instead of Edge.
I have been using chrome it was'nt working for me. The solution is to convert sharepoint default form to PowerApps.
Experiencing this as well. Do we think it is related to browser version (latest Edge vs older)? Works fine for me but not for a colleague. So bizarre that it wouldn't be the same experience for everyone. Went hunting through permissions but everything looks fine.

Does recreating the list resolve the issue?

@Noah Sparks  : The issue is resolved when you recreate the list.

I'm having the same issue and tried all of the fixes suggested. I did a fresh install of Chrome and it worked until a did a refresh of my browser. Then the same annoying error. Since it was a clean install of Chrome I had it delete ALL of my browser history, cookies, cache... the works. And then it started working again. It seems like the issue is something in the cache messing up the vailidation. It's annoying but at least I didn't have to recreate my list and I'll deal with it for now.

I was able to workaround this problem by editing the data in grid view.