teams private channel SharePoint site not showing content types from hub

%3CLINGO-SUB%20id%3D%22lingo-sub-3037043%22%20slang%3D%22en-US%22%3Eteams%20private%20channel%20SharePoint%20site%20not%20showing%20content%20types%20from%20hub%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3037043%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20am%20t%3CSPAN%3Erying%20to%20add%20content%20types%20from%20our%20Content%20Type%20Hub%20for%20the%20SPO%20site%20of%20Private%20Channel.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWhile%20I%20can%20enable%20content%20types%20usage%20in%20document%20libraries%20I%20cannot%20see%20%2F%20add%20any%20content%20types%20from%20our%20content%20type%20hub.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20Issue%20does%20not%20occur%20on%20normal%20SPO%20sites.%20I%20noticed%20in%20Site%20Settings%20the%20private%20channel%20does%20not%20have%20the%20same%20options%20for%20Content%20Types%20%26amp%3B%20Term%20Stores.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ECan%20you%20please%20advise%20how%20we%20go%20about%20enabling%20this%20functionality%20for%20Teams%20Private%20Channel%20SPO%20sites%20or%20if%20it%20is%20not%20supported.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThank%20you%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3037043%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3215205%22%20slang%3D%22en-US%22%3ERe%3A%20teams%20private%20channel%20SharePoint%20site%20not%20showing%20content%20types%20from%20hub%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3215205%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue%20in%20a%20SharePoint%20Site%2C%20I%20tried%20to%20enable%20the%20SharePoint%20server%20publishing%20Infrastructure%20feature%20but%20without%20luck.%20I'm%20still%20receiving%20the%20error%3A%20%22Sorry%2C%20there%20was%20a%20problem%20adding%20this%20content%20type.%20Please%20try%20again.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20have%20the%20solution%20for%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3038656%22%20slang%3D%22en-US%22%3ERe%3A%20teams%20private%20channel%20SharePoint%20site%20not%20showing%20content%20types%20from%20hub%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3038656%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1171147%22%20target%3D%22_blank%22%3E%40Ini%3C%2FA%3E%26nbsp%3B-%26nbsp%3BI%20remembered%20I%20had%20this%20issue%20before%20and%20had%20to%20activate%20%3CSTRONG%3ESharePoint%20Server%20Publishing%20Infrastructure%20%3C%2FSTRONG%3Ein%20the%20Site%20Collection%20Features.%20Once%20you%20do%2C%20you%20can%20deactivate%20it%20and%20things%20will%20still%20work%20as%20prior%20to%20the%20site%20is%20missing%20the%20content%20type%20publishing%20area%20in%20the%20settings%2C%20but%20after%20will%20still%20be%20there.%20So%20there's%20something%20in%20the%20back-end%20of%20that%20(my%20guess)%20that's%20required%20to%20add%20custom%20content%20types.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3038631%22%20slang%3D%22en-US%22%3ERe%3A%20teams%20private%20channel%20SharePoint%20site%20not%20showing%20content%20types%20from%20hub%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3038631%22%20slang%3D%22en-US%22%3EI%20see%20now%20that%20we%20can't%20add%20them%20the%20classic%20way%20(from%20the%20library%2Flist%20settings)%2C%20but%20via%20the%20library%2Flist%20front%20end%20(modern)%20using%20the%20column%20header%20drop-down%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fwhat-s-changed-in-content-type-publishing-609399c7-5c42-4e25-aff0-b59d4aa1867f%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fwhat-s-changed-in-content-type-publishing-609399c7-5c42-4e25-aff0-b59d4aa1867f%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EThat%20said%2C%20I%20get%20an%20error%20every%20time%20I%20try%20and%20add%20it%20this%20way%20regardless%20of%20which%20custom%20content%20type%20I%20choose%20-%20%22Sorry%2C%20there%20was%20a%20problem%20adding%20this%20content%20type.%20Please%20try%20again.%22%3CBR%20%2F%3E%3CBR%20%2F%3EI'll%20be%20submitting%20a%20support%20ticket%20with%20Microsoft%20for%20yet%20again%20another%20new%20feature%20rolled%20out%20that%20doesn't%20work.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3221887%22%20slang%3D%22en-US%22%3ERe%3A%20teams%20private%20channel%20SharePoint%20site%20not%20showing%20content%20types%20from%20hub%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3221887%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20will%20also%20add%20a%20steaming%20pile%20of%20unnecessary%20things%20to%20the%20Site%20Collection%20and%20should%20%3CU%3E%3CSTRONG%3ENEVER%3C%2FSTRONG%3E%20%3C%2FU%3Ebe%20done%20in%20a%20Modern%20site%20(or%20any%20other%20kind%20of%20site%2C%20these%20days).%3C%2FP%3E%3C%2FLINGO-BODY%3E
Super Contributor

Hello, 

 

Please am trying to add content types from our Content Type Hub for the SPO site of Private Channel.

 

While I can enable content types usage in document libraries I cannot see / add any content types from our content type hub.

 

The Issue does not occur on normal SPO sites. I noticed in Site Settings the private channel does not have the same options for Content Types & Term Stores.

 

Can you please advise how we go about enabling this functionality for Teams Private Channel SPO sites or if it is not supported.

 

Thank you

4 Replies
I see now that we can't add them the classic way (from the library/list settings), but via the library/list front end (modern) using the column header drop-down:
https://support.microsoft.com/en-us/office/what-s-changed-in-content-type-publishing-609399c7-5c42-4...

That said, I get an error every time I try and add it this way regardless of which custom content type I choose - "Sorry, there was a problem adding this content type. Please try again."

I'll be submitting a support ticket with Microsoft for yet again another new feature rolled out that doesn't work.

@IBN - I remembered I had this issue before and had to activate SharePoint Server Publishing Infrastructure in the Site Collection Features. Once you do, you can deactivate it and things will still work as prior to the site is missing the content type publishing area in the settings, but after will still be there. So there's something in the back-end of that (my guess) that's required to add custom content types.

I have the same issue in a SharePoint Site, I tried to enable the SharePoint server publishing Infrastructure feature but without luck. I'm still receiving the error: "Sorry, there was a problem adding this content type. Please try again."

 

Does anyone have the solution for this?

This will also add a steaming pile of unnecessary things to the Site Collection and should NEVER be done in a Modern site (or any other kind of site, these days).