Stop Sharing Button Not Working

Copper Contributor

I am trying to remove group access (Company Data Visitor) for a folder within a document library however the "Remove" button does not work. 


The steps i take to remove access is :

-Click on 3 dots for the folder i want to manage and select Manage Access.

-Under Direct Access select Company Data Visitors and click on Stop Sharing.

-When promoted with the following pop-up "Want to remove Company Data Visitor's Access?" select Remove. This then removes the group access for the folder. 


The above steps have worked fine for all folder except one. When i follow the above steps and get to the last stage, When promoted with the following pop-up "Want to remove Company Data Visitor's Access?" select Remove, the Remove button does not work.


When i click on Remove it just does nothing! This parent folder has MANY sub folders and then sub-sub folder... you get what i mean. I have checked all the sub folders and removed access to Company Data Visitors. I thought maybe this is stopping the parent folder from removing access to Company Data Visitors as the sub folder has permission to it, but this has not worked either.


I have not gone into each sub folder and then into each folder within the sub folder as this will take days!. I want to remove Data Visitors Access from the parent folder but cannot.. please can you advice on how i can achieve this.

4 Replies

Hi @KGak1,


Is the group that you are trying to remove one of the default groups for the site itself? Also, is the site connected an O365 group or is it a classic team site? Thanks!

Stephen Rice

Senior Program Manager, OneDrive

Hi @Stephen Rice 


I have the exact issue. It is a Team Site with an O365 group and the group that I am trying to remove access from is the Visitors group as the OP.

Hi @VladV30,


I have a suspicion that the reason the group keeps showing up is that it's actually being inherited from the parent (instead of being directly on the item). Can you try going into the Advanced permissions page (link at the bottom of Manage Access), fully breaking inheritance on the item & then deleting the permission (note that this may not be easily reversible, so probably try it on content you don't care about first)? Not 100% sure if that will solve but that's my best suggestion at the moment :) 


Stephen Rice

Senior Program Manager, OneDrive

@Stephen Rice 


I'll try it but deletion of this group from other folders in the same tree worked as expected. Only this one behaves like this. Maybe it is because of it's large number of subfolders.