SPO Root site creation process is halted whenever we try to create a new root site

%3CLINGO-SUB%20id%3D%22lingo-sub-653192%22%20slang%3D%22en-US%22%3ESPO%20Root%20site%20creation%20process%20is%20halted%20whenever%20we%20try%20to%20create%20a%20new%20root%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-653192%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20using%20Sharepoint%20Online%20and%20the%20past%20days%20we%20have%20been%20struggling%20with%20getting%20the%20root%20site%20up%20and%20running%20again.%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20started%20the%20process%20of%20wanting%20to%20replace%20the%20current%20root%20web%20with%20a%20new%20one%20to%20utilize%20the%20new%20communication%20site%20template.%20We%20read%20through%20various%20instructions%20on%20the%20web%20how%20to%20proceed.%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20started%20by%20deleting%20the%20current%20site%20and%20creating%20a%20new%20using%20Sharepoint%20admin%20classic%20GUI.%20The%20process%20initiated%20and%20the%20site%20is%20added%20to%20the%20list%20of%20sites%20with%20an%20animated%20status%20icon%20%2B%20a%20text%20stating%20%22the%20process%20may%20take%20up%20to%2024h%20to%20complete%22.%20After%2030-60%20minutes%20the%20status%2C%20all%20of%20a%20sudden%2C%20changes%20to%26nbsp%3B%20%22Removed%2FDeleted%22%20(it%20says%20%22Borttaget%22%20in%20Swedish).%20When%20I%20check%20the%20%22site%20trashcan%22%20I%20find%20the%20site%20newly%20created%20site%20and%20an%20animated%20status%20icon%20next%20to%20it%20(no%20status%20text).%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20I%20try%20to%20restore%20the%20site%20I%20just%20receive%20an%20error%20message%20%22Something%20went%20wrong.%26nbsp%3BThere%20is%20no%20site%20in%20the%20current%20site%20subscription%20matching%20the%20HiddenSiteSelection%20control's%20value.%20Technical%20information.%20Troubleshoot%20problem%20in%20Microsoft%20Sharepoint%20Foundation.%26nbsp%3B%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CP%3E%3CSPAN%3ECorrelation-ID%3A%206b1de19e-603e-8000-53ad-2121241a50be%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EDate%20and%20time%3A%202019-05-28%2011%3A18%3A15%22%3C%2FSPAN%3E%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20during%20the%20day%20retried%20several%20approaches%26nbsp%3B%20-%20Using%20different%20site%20templates%2C%20using%20default%20settings%2C%20using%20Powershell%20to%20delete%20the%20site%20(to%20ensure%20that%20the%20old%20site%20really%20is%20removed)%20and%20so%20on.%20But%20no%20luck%2C%20we%20end%20up%20with%20the%20same%20status%20result%20and%20no%20root%20site%20is%20created.%26nbsp%3B%26nbsp%3BThe%20administrator%20have%20the%26nbsp%3Bright%20permission%20level%20(Admin%20global).%3C%2FP%3E%3CP%3ECould%20the%20problem%20depend%20on%20delays%20in%20the%20deletion%2Fcreation%20process%20in%20the%20admin%20tool%20(the%20admin%20tool%20feels%20extremely%20slow).%20Should%20we%20wait%20longer%20until%20we%20retry%20the%20process%20or%20after%20each%20process%20step%3F%20Should%20we%20give%20the%20site%20a%20new%20name%20each%20time%20we%20try%3F%20Or%20is%20this%20kind%20of%20problem%20something%20that%20just%20can%20be%20solved%20by%20MS%20support%20staff%3F%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20yes..%20we%20now%20know%20and%20have%20learned%20the%20hard%20way%20that%20you%20shouldn't%20remove%20the%20Sharepoint%20root%20site.%20So%20no%20need%20of%20reminding%20me%20of%20the%20obvious%20%3B-).%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAny%20help%20appreciated!%3C%2FP%3E%3CPRE%3E%26nbsp%3B%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-653192%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-653712%22%20slang%3D%22en-US%22%3ERe%3A%20SPO%20Root%20site%20creation%20process%20is%20halted%20whenever%20we%20try%20to%20create%20a%20new%20root%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-653712%22%20slang%3D%22en-US%22%3EWhat%20you%20are%20experiencing%20here%20is%20one%20of%20the%20reasons%20why%20I%20don't%20recommend%20to%20delete%20the%20root%20site%20and%20create%20a%20new%20one...I%20have%20seen%20a%20lot%20articles%20explaining%20how%20to%20do%20it%2C%20but%20not%20of%20them%20explain%20the%20side%20effects%20that%20can%20happen...I%20would%20recommend%20to%20open%20a%20support%20ticket%20so%20Microsoft%20engineers%20can%20help%20you%20on%20fixing%20your%20root%20site.%20Also%20for%20your%20information%2C%20ability%20to%20conver%20the%20root%20site%20into%20a%20Communication%20Site%20is%20coming%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-654359%22%20slang%3D%22en-US%22%3ERe%3A%20SPO%20Root%20site%20creation%20process%20is%20halted%20whenever%20we%20try%20to%20create%20a%20new%20root%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-654359%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3B%20-%20thanks%20for%20your%20reply.%20We'll%20open%20a%20support%20ticket%20ASAP.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EJust%20found%20the%20roadmap%20info%20regarding%20the%20communication%20site.%20Thanks%20for%20the%20heads%20up!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We are using Sharepoint Online and the past days we have been struggling with getting the root site up and running again.

We started the process of wanting to replace the current root web with a new one to utilize the new communication site template. We read through various instructions on the web how to proceed. 

We started by deleting the current site and creating a new using Sharepoint admin classic GUI. The process initiated and the site is added to the list of sites with an animated status icon + a text stating "the process may take up to 24h to complete". After 30-60 minutes the status, all of a sudden, changes to  "Removed/Deleted" (it says "Borttaget" in Swedish). When I check the "site trashcan" I find the site newly created site and an animated status icon next to it (no status text).

If I try to restore the site I just receive an error message "Something went wrong. There is no site in the current site subscription matching the HiddenSiteSelection control's value. Technical information. Troubleshoot problem in Microsoft Sharepoint Foundation. 

Correlation-ID: 6b1de19e-603e-8000-53ad-2121241a50be

Date and time: 2019-05-28 11:18:15"

 

We have during the day retried several approaches  - Using different site templates, using default settings, using Powershell to delete the site (to ensure that the old site really is removed) and so on. But no luck, we end up with the same status result and no root site is created.  The administrator have the right permission level (Admin global).

Could the problem depend on delays in the deletion/creation process in the admin tool (the admin tool feels extremely slow). Should we wait longer until we retry the process or after each process step? Should we give the site a new name each time we try? Or is this kind of problem something that just can be solved by MS support staff? 

And yes.. we now know and have learned the hard way that you shouldn't remove the Sharepoint root site. So no need of reminding me of the obvious ;-). 


Any help appreciated!

 
2 Replies
Highlighted
What you are experiencing here is one of the reasons why I don't recommend to delete the root site and create a new one...I have seen a lot articles explaining how to do it, but not of them explain the side effects that can happen...I would recommend to open a support ticket so Microsoft engineers can help you on fixing your root site. Also for your information, ability to conver the root site into a Communication Site is coming

@Juan Carlos González Martín  - thanks for your reply. We'll open a support ticket ASAP. 

Just found the roadmap info regarding the communication site. Thanks for the heads up!