SPO People WebPart Photo Sync

%3CLINGO-SUB%20id%3D%22lingo-sub-872013%22%20slang%3D%22en-US%22%3ESPO%20People%20WebPart%20Photo%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-872013%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20seen%20plenty%20of%20articles%20on%20support%20channels%20relating%20to%20getting%20the%20User%20Profile%20Photo%20that%20has%20been%20uploaded%20to%20the%20Azure%20AD%20by%20admin%20to%20sync%20with%20the%20SharePoint%20Online%20People%20WebPart%20cards.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20photos%20have%20been%20reflected%20everywhere%20else%20in%20O365%2C%20and%20if%20I%20go%20to%20admin.microsoft.com%2C%20for%20any%20given%20user%2C%20their%20photo%20appears.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20a%20way%20to%20force%20refresh%20SPO.%20Needless%20to%20say%20that%20I%20cannot%20expect%2090%2B%20users%20to%20have%20to%20visit%20an%20incognito%20tab%20or%20their%20personal%20Delve%20to%20make%20this%20work%20first%20time%20round.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-872013%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873100%22%20slang%3D%22en-US%22%3ERe%3A%20SPO%20People%20WebPart%20Photo%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873100%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F414226%22%20target%3D%22_blank%22%3E%40NV_01%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20you%20trying%20to%20ask%20users%20to%20update%20their%20profile%20picture%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-873107%22%20slang%3D%22en-US%22%3ERe%3A%20SPO%20People%20WebPart%20Photo%20Sync%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-873107%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3E%3CBR%20%2F%3ENo%2C%20I%20have%20gone%20through%20Azure%20Active%20Directory%20and%20added%20a%20profile%20photo%20for%20everyone%20(I%20am%20an%20admin).%20However%2C%20these%20photos%20are%20not%20showing%20in%20the%20SPO%20Peoples%20Webpart%20but%20are%20showing%20in%20other%20places%20in%20O365%20such%20as%20outlook.%3CBR%20%2F%3E%3CBR%20%2F%3EHow%20can%20I%20force%20a%20refresh%20of%20SPO%20so%20that%20the%20photos%20sync%20with%20Azure%20AD%2FExchange%3F%3CBR%20%2F%3E%3CBR%20%2F%3EThanks.%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi,

 

I have seen plenty of articles on support channels relating to getting the User Profile Photo that has been uploaded to the Azure AD by admin to sync with the SharePoint Online People WebPart cards.

 

The photos have been reflected everywhere else in O365, and if I go to admin.microsoft.com, for any given user, their photo appears.

 

Is there a way to force refresh SPO. Needless to say that I cannot expect 90+ users to have to visit an incognito tab or their personal Delve to make this work first time round. 

 

Thanks.

2 Replies
Highlighted

@NV_01 

 

Are you trying to ask users to update their profile picture?

 

 

Highlighted
Hi,

No, I have gone through Azure Active Directory and added a profile photo for everyone (I am an admin). However, these photos are not showing in the SPO Peoples Webpart but are showing in other places in O365 such as outlook.

How can I force a refresh of SPO so that the photos sync with Azure AD/Exchange?

Thanks.