SPFX web part issue running gulp serve

%3CLINGO-SUB%20id%3D%22lingo-sub-1564058%22%20slang%3D%22en-US%22%3ESPFX%20web%20part%20issue%20running%20gulp%20serve%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1564058%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20have%20installed%20and%20was%20running%20the%20web%20parts%20by%20using%20commands%2C%20gulp%20serve%20in%20the%20past%20few%20days%20but%20now%20today%20after%20restarting%20my%20system%20when%20I%20run%20the%20command%20gulp%20serve%20in%20cmd%2C%20I'm%20getting%26nbsp%3B'gulp'%20is%20not%20recognized%20as%20an%20internal%20or%20external%20command.%20I%20do%20see%20not_modules%20folder%20and%20other%20folders%20but%20not%20sure%20why%20its%20not%20working%20now.%3C%2FP%3E%3CP%3EI%20do%20not%20want%20to%20reinstall%20npm%20gulp%20and%20want%20to%20know%20why%20this%20is%20happening%20if%20anyone%20experienced%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3E-Sal%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1564058%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1564110%22%20slang%3D%22en-US%22%3ERe%3A%20SPFX%20web%20part%20issue%20running%20gulp%20serve%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1564110%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F736673%22%20target%3D%22_blank%22%3E%40ejagmtg%3C%2FA%3E%26nbsp%3BI%20was%20not%20running%26nbsp%3Bnode.js%20command%20prompt%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi, I have installed and was running the web parts by using commands, gulp serve in the past few days but now today after restarting my system when I run the command gulp serve in cmd, I'm getting 'gulp' is not recognized as an internal or external command. I do see not_modules folder and other folders but not sure why its not working now.

I do not want to reinstall npm gulp and want to know why this is happening if anyone experienced this.

 

Thanks,

-Sal

 

1 Reply
Highlighted

@ejagmtg I was not running node.js command prompt